Bug 695054 - Fail to exercise the addition of a FTP-based package repository during installation.
Summary: Fail to exercise the addition of a FTP-based package repository during instal...
Keywords:
Status: CLOSED DUPLICATE of bug 679709
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-10 08:11 UTC by Tao Wu
Modified: 2014-10-28 23:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-23 09:58:21 UTC
Type: ---


Attachments (Terms of Use)
can 't read the metadata (98.47 KB, image/png)
2011-04-10 08:11 UTC, Tao Wu
no flags Details

Description Tao Wu 2011-04-10 08:11:24 UTC
Created attachment 491043 [details]
can 't read the metadata

Description of problem:
Failed to get the package metadata from additional repository, while the metadata's path is correct and the network is connected. 

Version-Release number of selected component (if applicable):
anaconda 15.27

How reproducible:
always

Steps to Reproduce:
1.Boot and initiate an install using any installation source 
2.Proceed through the installer until the Software Selection step 
3.At the software selection step, click Add additional software repositories and provide the information listed. Enter the following information, then select OK.
    * Repository type - HTTP/FTP
    * Repository URL -
      ftp://download.englab.nay.redhat.com/pub/fedora/linux/development/15/i386/os
    * Uncheck URL is a mirror list
  
Actual results:
Can not read the metadata from additional repository.

Expected results:
The package metadata from additional repository is read correctly 

Additional info:

Comment 1 He Rui 2011-04-11 08:30:19 UTC
Hi Tao, I can't reproduce your issue. My step is: 

1. Boot f-15-beta-rc2-i386(x86_64)-dvd.iso
2. Proceed with default settings until software selection step
3. At the software selection step, click 'Add additional software repositories'
and provide:

    * Repository name
    * Repository type - HTTP/FTP
    * Repository URL -
    ftp://download.englab.nay.redhat.com/pub/fedora/linux/development/15/i386/os

With the above steps, the ftp repo can be retrieved and installed as expected.

Can you please upload /tmp/anaconda.log when this error occurs? And is it similar to bug#679709?

Comment 2 Chris Lumens 2011-04-11 14:28:29 UTC
The last question is one I'm curious about too.  If you add an HTTP repo first, does the addition of the FTP repo then work?

Comment 3 bsfmig 2011-04-11 23:47:29 UTC
It's interesting when I attempted a same mirror ftp://mirrors.sohu.com/fedora/development/15/x86_64/os/ (run by Sohu Inc, China). In the VirtualBox install, anaconda fails to retrieve metadata, but in a VMware-based install, it did get it and finished cleanly.

Comment 4 Tao Wu 2011-04-13 09:41:35 UTC
(In reply to comment #1)
> Hi Tao, I can't reproduce your issue. My step is: 
> 
> 1. Boot f-15-beta-rc2-i386(x86_64)-dvd.iso
> 2. Proceed with default settings until software selection step
> 3. At the software selection step, click 'Add additional software repositories'
> and provide:
> 
>     * Repository name
>     * Repository type - HTTP/FTP
>     * Repository URL -
>    
> ftp://download.englab.nay.redhat.com/pub/fedora/linux/development/15/i386/os
> 
> With the above steps, the ftp repo can be retrieved and installed as expected.
> 
> Can you please upload /tmp/anaconda.log when this error occurs? And is it
> similar to bug#679709?

Hi Hurry,

Since other cases were tested in the same KVM environment after this case, the log file has been washed away. So I'm sorry that there are no valid log files now, next time I should save the related files in time.

The test result which appeared that time is not similar with bug#679709, because whether add a http repo first or not, it always can not read the metadata from additional repository.

Comment 5 Tao Wu 2011-04-13 09:56:36 UTC
Several tests on 32bit and 64bit has been done respectively today, but the test result has been totally different, while the test environment does not change. 
No matter on which arch, 32bit or 64bit, the package metadata from additional repository is read correctly.
If nothing changed on the ftp source, I think that might be a problem with my network status on that time. Perhaps the anaconda really did not achieved the file from the ftp source?

Comment 6 bsfmig 2011-04-13 13:44:23 UTC
No. When my testcase fails in VBox, I switched to tty2 and used ftp command but successfully retrieved several files on the same FTP server. Rebooting is of no help.
Maybe it be an issue of the virtual machine itself???

Comment 7 Radek Vykydal 2011-06-09 11:42:04 UTC
This looks like a duplicate of bug #679709. I found a reproducer of in which adding http:// repository didn't help too. It would actually help only if the ftp repo is added within 30 seconds from adding of the http repository (or from last successful ftp or http transfer generally).

Comment 8 Radek Vykydal 2011-06-09 11:43:14 UTC
(In reply to comment #7)
> This looks like a duplicate of bug #679709. I found a reproducer of 
of the bug #679709 I mean

Comment 9 Radek Vykydal 2011-06-23 09:58:21 UTC

*** This bug has been marked as a duplicate of bug 679709 ***


Note You need to log in before you can comment on or make changes to this bug.