Bug 69508 - segmentation fault upon -Uvh several files
segmentation fault upon -Uvh several files
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 69758 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-22 17:17 EDT by Michael Schwendt
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 13:21:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-22 17:17:31 EDT
From Bugzilla Helper:
# rpm -Uvh up2date*
Segmentation fault

# ls up2date*
up2date-2.9.16-7.x.9.i386.rpm
up2date-gnome-2.9.16-7.x.9.i386.rpm
up2date_script.txt

# rpm -Uvh up2date_script.txt 
up2date_script.txt: not a package manifest: 

# rpm -Uvh up2date-2.9.16-7.x.9.i386.rpm up2date_script.txt
Segmentation fault


Steps to reproduce:
1. rpm -Uvh anypackage.rpm /etc/services


Version-Release number of selected component (if applicable):
rpm-4.1-0.50

How reproducible:
Always

Additional information: Found by accident.
Comment 1 Jeff Johnson 2002-07-24 14:50:28 EDT
Hmmm, nice catch. Uninititialized pointer happens to be NULL
on 1st trip, happens to be non-NULL on remaining trips.
Fix is in rpm-4.1-0.55 when built.
Comment 2 Jeff Johnson 2002-07-25 07:20:28 EDT
*** Bug 69758 has been marked as a duplicate of this bug. ***
Comment 3 Aleksey Nogin 2002-08-08 13:21:46 EDT
I am not sure whether this is a new bug, or an old one, but with rpm-4.1-0.69 I
still see a similar crash:

% rpm -Kv up2date-2.9.33-7.x.9.i386.hdr up2date-2.9.33-7.x.9.i386.rpm
up2date-2.9.38-7.x.9.i386.rpm up2date-gnome-2.9.33-7.x.9.i386.hdr
up2date-gnome-2.9.33-7.x.9.i386.rpm up2date-gnome-2.9.38-7.x.9.i386.rpm

coredumps in

(gdb) bt
#0  0x4008772a in rpmReadSignature () from /usr/lib/librpm-4.1.so
#1  0x40076f62 in rpmVerifySignatures () from /usr/lib/librpm-4.1.so
#2  0x40077eb4 in rpmcliSign () from /usr/lib/librpm-4.1.so
#3  0x080499f7 in main ()
#4  0x42016664 in __libc_start_main () from /lib/i686/libc.so.6
Comment 4 Jeff Johnson 2002-08-08 13:28:21 EDT
Fixed in rpm-4.1-0.72:
- fix: check for lead magic, better error message on failure (#69751).

Please reopen if not.
Comment 5 Aleksey Nogin 2002-08-08 13:43:47 EDT
Yes, rpm-4.1-0.75 handles it w/o any crash.

Note You need to log in before you can comment on or make changes to this bug.