Bug 695144 - yumex can't find pytthon module "gconf" in LXDE environment
Summary: yumex can't find pytthon module "gconf" in LXDE environment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 699130 700314 (view as bug list)
Depends On:
Blocks: LXDE
TreeView+ depends on / blocked
 
Reported: 2011-04-10 21:39 UTC by G.Wolfe Woodbury
Modified: 2011-05-14 00:00 UTC (History)
5 users (show)

Fixed In Version: yumex-3.0.3-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-03 04:49:31 UTC


Attachments (Terms of Use)

Description G.Wolfe Woodbury 2011-04-10 21:39:09 UTC
Description of problem:
   In the Beta.RC2 LXDE live spin yumex cannot run due to a module "gconf" not found error:
[lxgw@lxde-nightly ~]$ yumex
Traceback (most recent call last):
  File "/usr/share/yumex/yumex.py", line 25, in <module>
    from yumexgui import YumexApplication
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 34, in <module>
    from yumexgui.gui import Notebook, PackageInfo, CompletedEntry, YumexStatusIcon
  File "/usr/lib/python2.7/site-packages/yumexgui/gui.py", line 27, in <module>
    import gconf, subprocess
ImportError: No module named gconf


Version-Release number of selected component (if applicable):
   yumex-3.0.2-1.fc15


How reproducible: every time


Steps to Reproduce:
1. install BETA.RC2 LXDE Live image to hard disk
2. run yumex from command line
3.
  
Actual results:
  traceback

Expected results:
  yumex runs

Additional info:
  in VBox guest with GConf2-gtk installed

Comment 2 Lukas Middendorf 2011-04-23 20:05:35 UTC
The fix indeed works. When will the rpm be updated?

Comment 3 Tim Lauridsen 2011-04-27 05:07:10 UTC
*** Bug 699130 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-04-27 06:57:56 UTC
yumex-3.0.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yumex-3.0.3-1.fc15

Comment 5 Fedora Update System 2011-04-27 06:58:09 UTC
yumex-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/yumex-3.0.3-1.fc14

Comment 6 Fedora Update System 2011-04-27 06:58:23 UTC
yumex-3.0.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/yumex-3.0.3-1.el6

Comment 7 Fedora Update System 2011-04-27 20:20:05 UTC
Package yumex-3.0.3-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing yumex-3.0.3-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yumex-3.0.3-1.el6
then log in and leave karma (feedback).

Comment 8 Tim Lauridsen 2011-04-28 12:03:12 UTC
*** Bug 700314 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2011-05-03 04:49:21 UTC
yumex-3.0.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-05-07 02:50:30 UTC
yumex-3.0.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-05-14 00:00:19 UTC
yumex-3.0.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.