Bug 695251 - var_export on negative array indexes returns unsigned index id
Summary: var_export on negative array indexes returns unsigned index id
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php
Version: 5.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-11 08:01 UTC by Patrick Uecker
Modified: 2012-02-21 06:29 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-02-21 06:29:54 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0249 normal SHIPPED_LIVE php bug fix and enhancement update 2012-02-20 15:07:10 UTC
PHP Bug Tracker 52534 None None None Never

Description Patrick Uecker 2011-04-11 08:01:02 UTC
Description of problem:

in php code having a negative array index - e.g. $dummy[-2]=123; - and using var_export($dummy,true) returns 2*MAXINT-1 as index id

further details listed here: http://bugs.php.net/52534


Version-Release number of selected component (if applicable):
CentOS 5.5 and 5.6

php.x86_64  5.1.6-27.el5_5.3  
php53.x8664 5.3.3-1.el5_6.1


How reproducible:
<?php

$dummy[-2]=123;
echo  "<br>";
echo var_export($dummy,true);
echo "<br>";

?>


Steps to Reproduce:
1. put php file on server
2. open it
3.
  
Actual results:
array ( 18446744073709551614 => 123, )

Expected results:
array ( -2=> 123, )

Additional info:
works fine with php.x86_64 5.1.6-27.el5

Comment 1 Joe Orton 2011-06-24 08:53:07 UTC
Thanks for the report.

Comment 5 errata-xmlrpc 2012-02-21 06:29:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0249.html


Note You need to log in before you can comment on or make changes to this bug.