Bug 695356 - user clamupdate does not exist
Summary: user clamupdate does not exist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: clamav-unofficial-sigs
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andrew Colin Kissa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-11 13:28 UTC by Jan ONDREJ
Modified: 2011-05-08 23:27 UTC (History)
1 user (show)

Fixed In Version: clamav-unofficial-sigs-3.7.1-4.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-08 23:27:23 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2011-04-11 13:28:58 UTC
Description of problem:
clamav-unofficial-sigs package does not work on centos/rhel. There is no clamupdate user in new clamav package.

Version-Release number of selected component (if applicable):
clamav-0.97-12.el5
clamav-unofficial-sigs-3.7.1-3.el5

How reproducible:
always

Steps to Reproduce:
1. yum install clamav-unofficial-sigs -y
  
Actual results:
warning: user clamupdate does not exist - using root
warning: group clamupdate does not exist - using root
warning: user clamupdate does not exist - using root
warning: group clamupdate does not exist - using root
warning: user clamupdate does not exist - using root
warning: group clamupdate does not exist - using root

Expected results:
no warnings

Additional info:
Looks like now clamav in epel uses different freshclam user. Also ls -la /var/lib/clamav shows:

[root@mail ~]# ls -la /var/lib/clamav
celkom 31788
drwxr-xr-x  2 clam clam     4096 apr 11 04:20 .
drwxr-xr-x 27 root root     4096 apr 11 15:22 ..
-rw-r--r--  1 clam clam   101879 mar 31 11:37 bytecode.cvd
-rw-r--r--  1 clam clam  6133248 apr 11 04:20 daily.cld
-rw-r--r--  1 clam clam 26224310 mar 30 12:26 main.cvd
-rw-------  1 clam clam      104 apr 11 04:20 mirrors.dat
[root@mail ~]# 

Also cron script was not started, guessing problem with unknown user.

Please, use "clam" user for EPEL package or report this problem to clamav maintainer to use same user for clamav databases on all OSes.

Comment 1 Andrew Colin Kissa 2011-04-11 14:26:48 UTC
This is a regression with the recent change in the EPEL clamav package, i will fix it.

Comment 2 Fedora Update System 2011-04-23 13:52:22 UTC
clamav-unofficial-sigs-3.7.1-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/clamav-unofficial-sigs-3.7.1-4.el5

Comment 3 Fedora Update System 2011-04-23 13:58:59 UTC
clamav-unofficial-sigs-3.7.1-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clamav-unofficial-sigs-3.7.1-4.el6

Comment 4 Fedora Update System 2011-04-23 18:26:18 UTC
Package clamav-unofficial-sigs-3.7.1-4.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing clamav-unofficial-sigs-3.7.1-4.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/clamav-unofficial-sigs-3.7.1-4.el5
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-05-08 23:27:15 UTC
clamav-unofficial-sigs-3.7.1-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-05-08 23:27:35 UTC
clamav-unofficial-sigs-3.7.1-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.