Bug 695389 - Traceback when writing a kickstart for an unused lvm-on-raid (TypeError: 'NoneType' object is not subscriptable)
Traceback when writing a kickstart for an unused lvm-on-raid (TypeError: 'Non...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
anaconda_trace_hash:9acc4941fc84851af...
:
: 696904 698249 (view as bug list)
Depends On:
Blocks: 494832 F15Blocker/F15FinalBlocker
  Show dependency treegraph
 
Reported: 2011-04-11 10:59 EDT by Clyde E. Kunkel
Modified: 2014-09-30 19:40 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-15.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-29 14:44:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (5.59 MB, text/plain)
2011-04-11 10:59 EDT, Clyde E. Kunkel
no flags Details
anaconda traceback when using bz695389.img (6.72 KB, text/plain)
2011-04-20 11:21 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Clyde E. Kunkel 2011-04-11 10:59:44 EDT
The following was filed automatically by anaconda:
anaconda 15.27 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 408, in majorminor
    dev = udev_get_device(sysfs_path[4:])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 1979, in writeKS
    pvs.append("pv.%s" % pv.format.majorminor)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1186, in writeKS
    device.writeKS(f, preexisting=preexisting, noformat=noformat)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/__init__.py", line 379, in writeKS
    self.storage.writeKS(f)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 67, in writeKSConfiguration
    anaconda.writeKS(fn)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1257, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1278, in handleRenderCallback
    self.currentWindow.renderCallback()
TypeError: 'NoneType' object is not subscriptable
Comment 1 Clyde E. Kunkel 2011-04-11 10:59:51 EDT
Created attachment 491254 [details]
Attached traceback automatically from anaconda.
Comment 2 Ales Kozumplik 2011-04-11 11:18:29 EDT
assigning this to me, I've seen similar issues.
Comment 3 Ales Kozumplik 2011-04-12 07:08:35 EDT
This is reproducible by trying to install on a system where lvm-on-raid exists which we do not touch during partitioning. The raid gets torn down and get_sysfs_path_by_name() returns None as /sys/class/block/md0 does not exist.
Comment 4 Ales Kozumplik 2011-04-12 13:34:02 EDT
Clyde,

can you please retest with this updates image?
http://akozumpl.fedorapeople.org/bz695389.img

Thank you.
Comment 5 Clyde E. Kunkel 2011-04-12 17:47:42 EDT
Hey, Ales:

Works fine. Normal end of install on LV over raid 10 with CD tray popping open...using the install now to report back to you. I'll leave open and let you close it when your changes show up.

Regards,
OldFart
Comment 6 Ales Kozumplik 2011-04-13 03:13:26 EDT
Proposing as a release blocker, this is easy to hit during upgrades or when installing to an unused disk while leaving other disks intact.
Comment 7 James Laska 2011-04-13 10:17:52 EDT
Qualifies as a final release [1] blocker per the following criteria:

   "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above "

While this is a kickstart-based installation, it still qualifies per the spirit of the above criteria.

[1] https://fedoraproject.org/wiki/Fedora_15_Final_Release_Criteria
Comment 8 Ales Kozumplik 2011-04-15 02:46:47 EDT
f15-branch: 1605b399f34ac923c457088d182da9db021191c8
master: 106f7d44099f2a11c156ed30d08f14d860c5d4be
Comment 9 Martin Gracik 2011-04-15 05:20:58 EDT
*** Bug 696904 has been marked as a duplicate of this bug. ***
Comment 10 Adam Williamson 2011-04-15 13:35:38 EDT
Discussed at the 2011-04-15 blocker review meeting. Accepted as a blocker as per jlaska's comment #7. Fix is in, waiting for a new anaconda build to confirm.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Chris Lumens 2011-04-20 10:25:09 EDT
*** Bug 698249 has been marked as a duplicate of this bug. ***
Comment 12 Patrick C. F. Ernzer 2011-04-20 11:21:06 EDT
Created attachment 493514 [details]
anaconda traceback when using  bz695389.img

Chris,

bz695389.img does not fix Bug 698249 for me. In fact, the updates image makes anaconda traceback a lot sooner.
Comment 13 Ales Kozumplik 2011-04-21 02:06:21 EDT
(In reply to comment #12)
> Created attachment 493514 [details]
> anaconda traceback when using  bz695389.img
> 
> Chris,
> 
> bz695389.img does not fix Bug 698249 for me. In fact, the updates image makes
> anaconda traceback a lot sooner.

Can you please attach the entire traceback file (it's named /tmp/anaconda-tb-*)?
Comment 15 Ales Kozumplik 2011-04-21 09:23:40 EDT
Patrick,

I think you are hitting a dup of bug 677689 (cciss devices' sysfs paths are not constructed properly). 

Can you please retest with http://akozumpl.fedorapeople.org/bz695389_patrick.img ?
Comment 16 Patrick C. F. Ernzer 2011-04-21 11:05:05 EDT
Ales,

(In reply to comment #15)
> I think you are hitting a dup of bug 677689 (cciss devices' sysfs paths are not
> constructed properly). 
> 
> Can you please retest with
> http://akozumpl.fedorapeople.org/bz695389_patrick.img ?

confirm, that updates image fixes Bug 698249 for me.
Thank you!

Will you adjust 698249 so that it is marked as DUP of the correct bug or do you want me to?
Comment 17 Robyn Bergeron 2011-04-21 13:22:51 EDT
From 04/21 blocker meeting - clumens expects a new build to arrive later today.
Comment 18 Ales Kozumplik 2011-04-22 02:05:23 EDT
> confirm, that updates image fixes Bug 698249 for me.
> Thank you!
> 
> Will you adjust 698249 so that it is marked as DUP of the correct bug or do you
> want me to?

I think it is okay to keep it as it is, those bugs are anyway all closely related and due to recent changes we made to those parts of the code.
Comment 19 James Laska 2011-04-25 10:50:22 EDT
NOTE: I think the fix for this bug, introduces bug#699383
Comment 20 Ales Kozumplik 2011-04-26 04:38:44 EDT
Comitted the fix for the problem from comment 14: cab0b376c390490cff2d0c378a490d3d5affec51.
Comment 21 James Laska 2011-04-29 12:29:19 EDT
anaconda-15-29.1 is now available in Fedora 15 'stable'. 

Clyde, are you still seeing this issue?  I'm guessing no since you were kind enough to add some bodhi karma to the update.  But I'll leave the request outstanding for a bit before we close this issue.
Comment 22 Clyde E. Kunkel 2011-04-29 14:44:08 EDT
No longer seeing.
Comment 23 James Laska 2011-04-29 14:44:43 EDT
(In reply to comment #22)
> No longer seeing.

Clyde you rock, thanks for the feedback :)

Note You need to log in before you can comment on or make changes to this bug.