Bug 6954 - Choosing which installation to upgrade didn't work
Summary: Choosing which installation to upgrade didn't work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-12 15:34 UTC by heikki
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-22 16:12:44 UTC


Attachments (Terms of Use)

Description heikki 1999-11-12 15:34:12 UTC
We wanted to upgrade an old RedHat 5.0 installation, and at the same time
use a different root partition. So, we copied whole installation from
/dev/hda2 to /dev/hdb2, sticked in a boot diskette, and tried to upgrade
over ftp (that machine did not have a CD).

Answered /dev/hda to the question which one to upgrade.

All went smoothly, until we were informed that we didn't have enough disk
space (on a 1500M partition, filled with about 900M of the old
installation). (I report the disk size calculations as a separate bug)

Tried to delete stuff we were sure wouldbe reinstalled, and nothing helped.
Turned out that the install was trying to put things on hdb2. It had
mounted /dev/hdb2 as /mnt/sysimage(?)/ and hda2 as /mnt/sysimage/a2.

In the end we Fdisk'd /dev/hdb2 into an empty partition, so that the
installer would not find it, and would be forced to upgrade hda2. This
seemed to work, but we hit the disk size problem again, and had to stop for
today. Fdisk-created hd2 to Linux again, fsck'd it, and booted back to
normal.

Comment 1 Jay Turner 1999-11-29 20:09:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Jay Turner 2000-02-22 16:12:59 UTC
This issue is resolved in the latest cut of the installer.


Note You need to log in before you can comment on or make changes to this bug.