Bug 695405 - non-latin characters in default gnome-shell look different from the Cantarell
Summary: non-latin characters in default gnome-shell look different from the Cantarell
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: abattis-cantarell-fonts
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cosimo Cecchi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-11 16:04 UTC by Aleksandra Fedorova
Modified: 2013-04-30 22:55 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-12 13:16:40 UTC
Type: ---


Attachments (Terms of Use)
example titles and text (65.36 KB, image/png)
2011-04-11 16:04 UTC, Aleksandra Fedorova
no flags Details
Pidgin conversation window as a better example (77.72 KB, image/png)
2011-04-11 16:33 UTC, Aleksandra Fedorova
no flags Details
Good example of problem. (741.90 KB, image/png)
2011-04-28 06:52 UTC, Alexei Panov
no flags Details

Description Aleksandra Fedorova 2011-04-11 16:04:42 UTC
Created attachment 491272 [details]
example titles and text

Originally posted in Gnome Bugzilla
https://bugzilla.gnome.org/show_bug.cgi?id=647020

Cyrillic fonts, used by default are different from Cantarell in average color and size.

I use Fedora Live RC1 Beta. And my system locale is en_US.UTF-8.

I attached a screen with Firefox titles, Overview-mode title and Pidgin contact
window. (In Empathy it looks the same.)

Most annoying are fonts in Pidgin or Empathy conversations. Mixture of latin
nicknames, commands and so on with cyrillic words which are twice as bigger.

Comment 1 Aleksandra Fedorova 2011-04-11 16:33:50 UTC
Created attachment 491279 [details]
Pidgin conversation window as a better example

Comment 2 Alexei Panov 2011-04-28 06:52:22 UTC
Created attachment 495420 [details]
Good example of problem.

I confirm this bug.
On screenshot one application and one font but different languages.

Comment 3 TNO-reg 2011-05-29 06:04:20 UTC
This bug also has happened to me, just like on the screenshots above. As a partial workaround for those who might need it, I have installed gnome-tweak-tool and changed the fonts from Cantarell to Sans (which works as an alias to DejaVu Sans, I suppose) which did the trick.

Comment 4 Hidden 2011-06-24 21:47:38 UTC
Default DE font which does not support Cyrillic is an insult for international community. It should be addressed ASAP.

Comment 5 tawakiy 2011-09-03 16:03:42 UTC
I confirm this bug.
Default font for international software without support for other - non-latin symbols - are wrong.

Comment 6 Akira TAGOH 2011-09-29 05:52:24 UTC
Have we had any discussion to change the default font in any list BTW? we have used DejaVu fonts as default for Latin though. AFAIK abattis-cantarell-fonts doesn't have the fontconfig config file to behave so. it's not a bug for fontconfig anyway.

Comment 7 Fedora Admin XMLRPC Client 2012-01-10 15:41:51 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 8 Fedora Admin XMLRPC Client 2012-03-22 01:38:00 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 9 Akira TAGOH 2012-04-05 10:03:25 UTC
reading again, and I'd say again. it's not a bug in fontconfig. as it's suggested in upstream bug referred in comment#1, better solution would be to include cyrillic glyphs in cantarell fonts. reassigning.

Comment 10 Aleksandra Fedorova 2012-04-05 12:52:39 UTC
I think there are actually two bugs in one:

First: the lack of cyrillic glyphs in Cantarell font. But this could be addressed as a feature request, not a bug, and we cannot force the designers to create the cyrillic part of the font if they do not want to or not interested or just don't have enough time for it.

Second: the bug in the use of Canratell font without cyrillics: it uses some font as a fallback for non-existent glyphs and we need to change the settings of these fallback font in such a way, that it looks less differnet from the Cantarell. Can we at least adjust the size of this fallback font?

Comment 11 Nicolas Mailhot 2012-04-05 13:19:30 UTC
Either way the problem is in the cantarell package since it can (and should) specify its own fallback rules.

However Cantarell is a new design, and I don't think it included consideration for the metrics of existing fonts, so there is probably no metrically-compatible font to fallback to.

Comment 12 Aleksandra Fedorova 2012-04-05 14:05:26 UTC
Please take a look at Cantarell Cyrillic here:
http://atolstoy.wordpress.com/2011/11/09/cantarell-cyr/

The direct link to the font file: 
http://kknight.narod.ru/Cantarell-Regular-cyr.ttf.tar.gz

Can you add its cyrillic glyphs for default Cantarell may be? Or just use it as a base. It is not superb and may need some edits, but anyway looks much better then the default combination.

I can contact the author for any details if needed.

Comment 13 Jakub Steiner 2012-04-12 11:32:22 UTC
I've merged initial Cyrillic support for Cantarell upstream. It will be included in the 0.0.9 release.

Comment 14 Cosimo Cecchi 2012-04-12 13:16:40 UTC
Thanks Jakub, closing as UPSTREAM,

Comment 15 Peter Lemenkov 2012-04-14 17:22:35 UTC
(In reply to comment #14)
> Thanks Jakub, closing as UPSTREAM,

Absolutely bogus reason for closing. I mean someone reported you about an issue, and you just told him - "it has been closed somewhere, no need to worry". Despite of being fixed somewhere our Fedora user still suffers from the issue since it wasn't fixed in Fedora yet.

#justsaying.

Comment 16 Cosimo Cecchi 2012-04-16 13:33:39 UTC
(In reply to comment #15)

> Absolutely bogus reason for closing. I mean someone reported you about an
> issue, and you just told him - "it has been closed somewhere, no need to
> worry". Despite of being fixed somewhere our Fedora user still suffers from the
> issue since it wasn't fixed in Fedora yet.

No, what actually happened is someone reported a missing feature, I forwarded it to Jakub which spent time and hard work and implemented the feature upstream, and you're whining instead of thanking him.
There's no reason to track this bug in two different locations, since Fedora tracks upstream releases for Cantarell: you will be able to use the new font when a release is out for it.


Note You need to log in before you can comment on or make changes to this bug.