Bug 69547 - "nis" doesn't seem to work with pam_unix/password
"nis" doesn't seem to work with pam_unix/password
Status: CLOSED DUPLICATE of bug 115309
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-07-22 21:43 EDT by Marc MERLIN
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-10 04:46:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Make pam change nis and local password (887 bytes, patch)
2004-04-16 18:49 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Marc MERLIN 2002-07-22 21:43:51 EDT
authconfig seems to insist on adding "nis" to /etc/pam.d/system-auth when you
tell RH that you use NIS.
This fails miserably when you try to change your local root password obviously,
and I'm not sure it actually lets you change any local password anymore for that
I've suggested in bug 69546 that authconfig does not add "nis" to the password
line for pam_unix

That said, I've tried to change a nis password that way:
bash-2.05a$ passwd
Changing password for user merlin.
Changing password for merlin
(current) UNIX password: 
New password: 
Retype new password: 
passwd: all authentication tokens updated successfully.

you'd think it worked, but it failed silently. My password wasn't changed, and
if I change it with yppassword, I can change it just fine.

That said, the bug wouldn't bother me much if authconfig didn't stick "nis"
there in the first place
Comment 1 Orion Poplawski 2004-04-16 18:49:36 EDT
Created attachment 99502 [details]
Make pam change nis and local password

The _do_setpass() command in modules/pam_unix/pam_unix_passwd.c will only set
the nis password if nis is listed in /etc/pam.d/system-auth.  The above patch
will change the behavior to also set the local password.  One catch is that any
possible errors setting the local password are not caught.

The patch is against the pam-0.77 code from the Fedora Core 1 src.rpm
Comment 2 Tomas Mraz 2004-11-10 04:46:26 EST

*** This bug has been marked as a duplicate of 115309 ***

Note You need to log in before you can comment on or make changes to this bug.