Bug 695584 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED DUPLICATE of bug 718183
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-12 01:34 EDT by Jóhann B. Guðmundsson
Modified: 2011-08-03 08:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-03 08:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd service file for snmp daemon (299 bytes, text/plain)
2011-04-12 01:34 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for snmp trap daemon (303 bytes, text/plain)
2011-04-12 01:35 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-12 01:34:23 EDT
Created attachment 491406 [details]
Native systemd service file for snmp daemon

Description of problem:

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-04-12 01:35:16 EDT
Created attachment 491407 [details]
Native systemd service file for snmp trap daemon
Comment 2 Jóhann B. Guðmundsson 2011-04-12 01:37:33 EDT
To test the submitted files copy them into /lib/systemd/system and run systemctl daemon-reload then systemctl start/restart/stop/status $foo.service
Comment 3 Bill Nottingham 2011-04-26 13:35:31 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 5 Marcela Mašláňová 2011-08-02 03:39:53 EDT
*** Bug 695589 has been marked as a duplicate of this bug. ***
Comment 6 Marcela Mašláňová 2011-08-02 03:39:59 EDT
*** Bug 695597 has been marked as a duplicate of this bug. ***
Comment 7 Jan Safranek 2011-08-03 08:20:14 EDT

*** This bug has been marked as a duplicate of bug 718183 ***

Note You need to log in before you can comment on or make changes to this bug.