This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 695598 - Python-client still require --version-name and --version-desc to create version
Python-client still require --version-name and --version-desc to create version
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
1.3-alpha-1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 02:38 EDT by Ding-Yi Chen
Modified: 2011-10-28 03:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:25:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2011-04-12 02:38:52 EDT
Description of problem:
In web UI, the version name and version desc fields are removed to
avoid confusion and complication.

However, zanata-python-client still requires following two options:
  --version-name
  --version-des
to create version

Version-Release number of selected component (if applicable):
zanata-python-client-1.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. Assume zanata.ini is configured.
2. zanata project create <projectId> --project-name=<projectName> --project-desc=<projectDesc> --url=<serverUrl>
3. zanata version create <versionId> --project-id=<projectId> --url=<serverUrl>
  
Actual results:
error: Please provide Iteration name by '--version-name' option

Expected results
Success without error

Additional info:
Comment 1 James Ni 2011-04-12 22:58:28 EDT
I removed the check for '--version-name', zanata-python-client will not require two options now. Please use the commit 7be3cde2cf756703fc49 of devel branch of zanata python client on github for testing.
Comment 2 Ding-Yi Chen 2011-04-13 19:57:27 EDT
Indeed, absent of --version-name and --version-desc does not show error. However, it does not show "Success create the version <VER>" either.

Two more concerns:
1. It's better to use "Successfully created the version <VER>"
2. After I cloned the zanata-python-client and type 'make'.
   It does create a VERSION_FILE, but zanata require it to be
   in zanataclient to work.

Regards.
Comment 3 James Ni 2011-04-19 00:20:53 EDT
1. It's better to use "Successfully created the version <VER>"
>>> It's modified in commit 0921349 by Sean

2. After I cloned the zanata-python-client and type 'make'.
   It does create a VERSION_FILE, but zanata require it to be
   in zanataclient to work.

>>> This issues was updated by commit 7f0f3d0

please test and verify with the latest commit
0e90977 of devel branch of zanataclient on github, since i merge
some changes from server.
Comment 4 Ding-Yi Chen 2011-04-19 22:45:43 EDT
Tested on commit b1df3d6c9a5a58ab65c13b0366a24b1a2b31c988

Passed when communicate with server 1.3,
yet still failed on server 1.2.

A quick fix is: if server 1.2 is detected and --version-name is not given,
then we assign --version-name=<version-id>


Regards.
Comment 5 James Ni 2011-04-20 23:24:12 EDT
I add a check for server version, if server version equal or less than 1.2 and --version-name is not given, we will copy version-id to version-name, the changes is in commit 517cbc1 of devel branch of zanataclient on github.

Best Regards.
Comment 6 Ding-Yi Chen 2011-07-05 20:47:26 EDT
VERIFIED with commit  8462ad8d5dc8c2d9ec1ebf6234c651aa64e96579

Note You need to log in before you can comment on or make changes to this bug.