Bug 695599 - Internal error in yum
Internal error in yum
Status: CLOSED DUPLICATE of bug 672932
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 02:50 EDT by Peter H. Jones
Modified: 2014-01-21 18:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-12 08:49:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages appearing in "Show Detail" in package kit update window (1.18 KB, application/octet-stream)
2011-04-12 02:50 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2011-04-12 02:50:40 EDT
Created attachment 491414 [details]
messages appearing in "Show Detail" in package kit update window

Description of problem:
Internal error in backend

Version-Release number of selected component (if applicable):
Unknown. When I try to run yum, I get:

"[root@localhost jones]# yum --help
error: rpmdb: Thread/process 1704/140150790620960 failed: Thread died in Berkeley DB library
error: db4 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db4 -  (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed
"

How reproducible:
Always

Steps to Reproduce:
1. Trying to install debug packages with Add/Remove software, because abrt was getting "operation not permitted" messages when trying to download debug info.
2.
3.
  
Actual results:
Can't open rpmdb. Would like to know if I can get it back without reinstalling whole system.

Expected results:
Normal bug reporting

Additional info:
Comment 1 Peter H. Jones 2011-04-12 08:49:10 EDT
After searching with Google, I rediscovered the rpm --rebuilddb command. That fixed up my RPM database. Whew!

*** This bug has been marked as a duplicate of bug 672932 ***

Note You need to log in before you can comment on or make changes to this bug.