Bug 6958 - System freeze under KDE/GNOME/Window Managers
System freeze under KDE/GNOME/Window Managers
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Depends On:
  Show dependency treegraph
Reported: 1999-11-12 12:25 EST by Oliver Richman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-01-14 12:35:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Oliver Richman 1999-11-12 12:25:07 EST
Bug Report:

Description of Problem:
  If any KDE or Gnome application is run, or anything on the AnotherLevel
bar is used, the system will freeze within 3 minutes.

  The mouse cursor dissapears and I cannot type anything. I cannot toggle
numlock or reboot using CTRL-ALT-DEL.

Problem does not affect:
  Non-X Linux, Normal X, AnotherLevel menus(maybe), "failsafe" mode from
  an X display manager, MS-Windows programs (under MS-Windows).

  I installed RedHat 6.1 and was gradually shrinking the size of my
windows partition, in a premeditated move to delete it and run only Linux.
Everything worked fine at this point. Then I uninstalled GNOME in order to
move to KDE. I did this by using rpm to remove every gnome package on my
system. I then bought a Paradise External Modem because my AOpen PCI modem
didn't work, and decided to buy a Cirrus Logic 5465 PCI video card to
replace my old, snow-bound Cirrus Logic 5446 PCI video card.

When I installed the new hardware, I decided to reinstall GNOME, by using
rpm on all the GNOME packages. No errors here.

I noticed that everything worked better except with this new hardware
except that if I ran any KDE or GNOME application, including only kvt or
the Gnome terminal, the system would crash within a few minutes. The
problem and may not exist if I only run AnotherLevel or regular
X, since I have not experienced the problem running either of those two
configurations. Of course, the problem does not ever occurr using the
Linux terminal.

POSSIBLE CAUSE: Bad X drivers? Problems with KDE and/or GNOME?

I doubt it is actually a problem with KDE or GNOME, because both desktop
environments seem to cause this problem. So I strongly suspect it is a
configuration error or a problem with the X drivers for the CL-5465
chipset. However if you know ANY WAY I *MIGHT* be able to fix this
problem, then please tell me! I'd do anything to run KDE. You see, I am
trying to impress my boss into using Linux + StarOffice/KOffice at work (5
computers) instead of MS-Windows + Office, and this is the critical
juncture. I need it to work for at least 20 minutes in a row.. Please
help :)

  RedHat 6.1 (Cartman) distribution kernel 2.2.10.
  Intel Celeron 300MHZ processor
  Cirrus Logic PCI 5465 Video Card, 4megs / AGP
  ECom monitor (www.ecomcom.com) set to "Generic Multiscan" in X11 config.
  Paradise 56k External Modem
  Unconfigured Yamaha OPL soundcard (ISA PnP)
  Unconfigured HP ScanJet 5p ISA card.
  96 megs ram, 3gb hd, "SoundBlaster" CDROM.


Oliver Richman

Cc: KDE bugs list
Cc: GNOME bugs list
Comment 1 Oliver Richman 1999-11-12 22:41:59 EST
Dear Sir; I have resolved this problem. It is a buggy X driver! In order to use
these cards, please use a colour depth of 16 bits at 1024x768 (or whatever). The
reason they crash is because the C drivers don't like the 32 bit colour depth I
was using. 24 bit depth is yet untested but hey, who cares, i'm in 1024x768 mode
and it RUNS GREAT! :)
Comment 2 Oliver Richman 1999-11-12 22:42:59 EST
Oops, make that X drivers. Even thought they *were* probably written in C... hee
Comment 3 Preston Brown 2000-01-14 12:35:59 EST
this will be fixed for the next release.

Note You need to log in before you can comment on or make changes to this bug.