Bug 69595 - Atd fails to properly start jobs
Atd fails to properly start jobs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: at (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-23 12:16 EDT by Mike Gahagan
Modified: 2012-01-10 21:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 12:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix problems noted above. (6.51 KB, patch)
2002-07-23 12:17 EDT, Mike Gahagan
no flags Details | Diff

  None (edit)
Description Mike Gahagan 2002-07-23 12:16:01 EDT
Description of Problem:

1. It deletes entries in the "=" queue after one hour, even if they are
not technically stale, i.e. the job is still running. We haven't changed
this since it does not affect correctness; the user will just see the job
dissapear from the "=" queue even if it's still runnning.

2. There is a race condition between at and atd that can delay job
execution by one hour. We have changed this to 5 minutes since a proper
fix would involve some serious changes.

3. There is a race condition that allows "atd" to miss starting jobs. We
have fixed this by making it such that it will check the job directory
every time it is woken up; We are now testing this fix.


Version-Release number of selected component (if applicable):

3.1.8-23 with the patches that fixed problems reported in #67414

How Reproducible:

Somewhat intermittent, submitting jobs which take a long time (> 1hr) to
complete is the best way to reproduce these. An SMP system also seems to help.


Steps to Reproduce:
1. 
2. See above
3. 

Actual Results:

See above

Expected Results:

Jobs should complete properly, and not be removed from the queue until acutally
complete.

Additional Information:
	

attached patch applies cleanly to 7.3 at package and should fix the problems,
but a little more testing is needed.
Comment 1 Mike Gahagan 2002-07-23 12:17:05 EDT
Created attachment 66624 [details]
patch to fix problems noted above.
Comment 2 Bill Huang 2002-07-24 22:32:47 EDT
It is fixed.(3.1.8-31)

Note You need to log in before you can comment on or make changes to this bug.