Bug 695951 - RHEL6.1 BOOTX64.efi cannot handle being called "bootx64"
RHEL6.1 BOOTX64.efi cannot handle being called "bootx64"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub (Show other bugs)
6.1
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Jones
Release Test Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-12 18:50 EDT by Russ Anderson
Modified: 2013-08-30 00:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On certain UEFI-based systems, you may need to type BOOTX64 rather than bootx64 to boot the installer due to case sensitivity issues.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-16 09:23:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russ Anderson 2011-04-12 18:50:28 EDT
Description of problem:

Typing "bootx64" (lowercase) ends up in an empty grub menu rather than 
booting the installer.  This is one EFI which is case insensitive.


Version-Release number of selected component (if applicable):

RHEL6.1-SNAP2

How reproducible:

100%

Steps to Reproduce:
1. At the EFI shell prompt "cd efi", "cd redhat", "bootx64".

  
Actual results:

Drops to an empty grub menu.

Expected results:

Boot the installer the same as if "BOOTX64" was typed.

Additional info:

When "BOOTX64" is used, BOOTX64.efi looks for BOOTX64.conf to find the grub
menu settings.  When "bootx64" is used, it behaves as if BOOTX64.efi
(which EFI calls) looks for bootx64.conf (lowercase) which does not 
exits and so it goes into an empty grub menu.  

The reason this is a problem is since EFI is case insensitive, the assumption
is that "bootx64" should work the same as "BOOTX64".

After installing RHEL6.1, if grub.efi is copied to BOOT.efi and grub.conf
is copied to BOOT.conf (in /boot/efi/EFI/redhat/) typing "boot" 
(lowercase) does work (even though BOOT.conf is uppercase).  So BOOTX64.efi
is handling case differently than grub.efi.
Comment 2 Brian Lane 2011-04-12 20:32:17 EDT
If grub.conf exists and no other config file is found it will use that.
Comment 3 RHEL Product and Program Management 2011-04-13 02:01:21 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Russ Anderson 2011-04-13 10:49:20 EDT
There is no grub.conf on the install DVD.  The only config file is BOOTX64.conf.
Unfortunately BOOTX64.conf does not get used if "bootx64" (lowercase) is
specified.

fs2:\EFI\BOOT> ls
Directory of: fs2:\EFI\BOOT

  04/11/11  04:01a <DIR>          2,048  .
  04/11/11  04:01a <DIR>          2,048  ..
  04/11/11  04:01a                1,341  splash.xpm.gz
  04/11/11  04:01a              247,570  BOOTX64.efi
  04/11/11  04:01a                  429  BOOTX64.conf
          3 File(s)     249,340 bytes
          2 Dir(s)


fs2:\EFI\BOOT>
fs2:\EFI\BOOT> type bootx64.conf
type: fs2:\EFI\BOOT\BOOTX64.conf, Size 429

#debug --graphics
default=0
splashimage=/EFI/BOOT/splash.xpm.gz
timeout 5
hiddenmenu
title Red Hat Enterprise Linux 6.1
	kernel /images/pxeboot/vmlinuz
	initrd /images/pxeboot/initrd.img
title Install system with basic video driver
	kernel /images/pxeboot/vmlinuz xdriver=vesa nomodeset askmethod
	initrd /images/pxeboot/initrd.img
title rescue
	kernel /images/pxeboot/vmlinuz rescue askmethod
	initrd /images/pxeboot/initrd.img

fs2:\EFI\BOOT> 
fs2:\EFI\BOOT> bootx64


    GNU GRUB  version 0.97  (572K lower / 1928060K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]

grub>
Comment 6 Russ Anderson 2011-04-13 10:54:29 EDT
I should add that once at the empty grub menu if the user quits out of grub
to get back to the EFI shell prompt, they cannot because apparently the
mapping is gone (unmounted?).  Reset is the only way to get back to try to
boot again.

--------------------------------------------------
grub> quit                                                                     

fs2:\EFI\BOOT> ls
ls/dir: Cannot open current directory - No Mapping
Exit status code: No Mapping
Invalid file system mapping on fs2


fs2:\EFI\BOOT>
Comment 7 David Cantrell 2011-05-16 10:46:50 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
On certain UEFI-based systems, you may need to type BOOTX64 rather than bootx64 due to case sensitivity issues.
Comment 8 RHEL Product and Program Management 2011-05-20 11:54:49 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 9 Russ Anderson 2011-05-23 18:58:41 EDT
Why can't BOOTX64.efi be changed to work like grub.efi?
Comment 10 Martin Prpic 2011-11-10 11:30:22 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-On certain UEFI-based systems, you may need to type BOOTX64 rather than bootx64 due to case sensitivity issues.+On certain UEFI-based systems, you may need to type BOOTX64 rather than bootx64 to boot the installer due to case sensitivity issues.

Note You need to log in before you can comment on or make changes to this bug.