Bug 695971 - Hangul Keybaord Layout works to only dubeolsik
Summary: Hangul Keybaord Layout works to only dubeolsik
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-hangul
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-13 00:55 UTC by sangu
Modified: 2011-05-27 20:23 UTC (History)
5 users (show)

Fixed In Version: ibus-hangul-1.3.1-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-27 20:23:35 UTC
Type: ---


Attachments (Terms of Use)

Description sangu 2011-04-13 00:55:42 UTC
Description of problem:
Hangul Keyboard Layout works to only dubeolsik.

Version-Release number of selected component (if applicable):
1.3.99.20110228-6.fc15.x86_64

How reproducible:
Sometimes. 

Steps to Reproduce:
Lanuch gedit
1. Enable korean input method
2. Click IBusHangul Setup
3. Change to Sebeolsik390 
4. type kf 
  
Actual results:
라 

Expected results:
가

Additional info:

ibus-hangul-1.3.1-1.fc15.x86_64

Comment 1 Daiki Ueno 2011-04-13 01:16:56 UTC
Reassigning from ibus to ibus-hangul.

Can you do some tests to determine where is the bug (ibus-hangul, libhangul, or ibus)?

1. Is the gconf setting properly updated?

 $ gconftool-2 -g /desktop/ibus/engine/Hangul/HangulKeyboard
 => 39

2. Does libhangul convert 'kf' to 가?

 $ hangul -k 39 -i 'kf'
 => 가

Comment 2 sangu 2011-04-13 01:58:36 UTC
(In reply to comment #1)
> Reassigning from ibus to ibus-hangul.
> 
> Can you do some tests to determine where is the bug (ibus-hangul, libhangul, or
> ibus)?
> 
> 1. Is the gconf setting properly updated?
> 
>  $ gconftool-2 -g /desktop/ibus/engine/Hangul/HangulKeyboard
>  => 39
> 
> 2. Does libhangul convert 'kf' to 가?
> 
>  $ hangul -k 39 -i 'kf'
>  => 가
Then, because ibus restart, your testcase works well.
1. $ gconftool-2 -g /desktop/ibus/engine/Hangul/HangulKeyboard
39
2. $ hangul -k 39 -i 'kf
가

Comment 3 Daiki Ueno 2011-04-13 02:17:41 UTC
(In reply to comment #2)
> Then, because ibus restart, your testcase works well.
> 1. $ gconftool-2 -g /desktop/ibus/engine/Hangul/HangulKeyboard
> 39
> 2. $ hangul -k 39 -i 'kf
> 가

Well, could you try them when you see the wrong behavior?  As you say "How reproducible: Sometimes", I have not yet reproduced the problem here.

Comment 4 Daiki Ueno 2011-05-11 08:50:12 UTC
I could finally reproduce this yesterday (though I have not reproduced again since then) with ibus-1.3.99.20110408-3 and ibus-hangul-1.3.1-1.  Yes, at that time the above test cases returned the correct values - so I guess ibus-hangul (or ibus) were losing "config-value-changed" signal, or libhangul input context was reset after that signal.

Can you provide more input to reproduce this again?

Comment 5 Daiki Ueno 2011-05-11 09:43:08 UTC
Ah, I probably got it.  There was a problem in my patch to support ibus-1.4, where ibus_hangul_init() does not reset the return pointer passed to config_get_string() which expects it NULL.

Koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3065669

I'm about to submit an update for F-15.  If this is not the case, please add a comment here.

Comment 6 Fedora Update System 2011-05-11 09:43:54 UTC
ibus-hangul-1.3.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-hangul-1.3.1-3.fc15

Comment 7 Fedora Update System 2011-05-14 03:08:10 UTC
Package ibus-hangul-1.3.1-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-hangul-1.3.1-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-hangul-1.3.1-3.fc15
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-05-27 20:23:30 UTC
ibus-hangul-1.3.1-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.