Bug 696087 - llvm version number woes in yum
llvm version number woes in yum
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-13 04:56 EDT by Paul Bolle
Modified: 2011-08-02 18:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 18:00:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Bolle 2011-04-13 04:56:56 EDT
Description of problem:
Latest llvm (and friends) in Rawhide have version 2.9-0.1.rc2.fc16. Previous llvm (and friends) had version 2.9-0.2.rc1.fc16.

Currently I have llvm and llvm-libs installed with version 2.9-0.2.rc1.fc16. That is a higher version for yum purposes than the latest version available in Rawhide. This means I can't yum install llvm-devel due to version number woes.

Version-Release number of selected component (if applicable):
llvm-2.9-0.1.rc2.fc16

How reproducible:
Always

Steps to Reproduce:
1. yum install llvm-devel
2.
3.
  
Actual results:
$ sudo yum install llvm-devel
Loaded plugins: refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package llvm-devel.i686 0:2.9-0.1.rc2.fc16 will be installed
--> Processing Dependency: llvm = 2.9-0.1.rc2.fc16 for package: llvm-devel-2.9-0.1.rc2.fc16.i686
--> Finished Dependency Resolution
Error: Package: llvm-devel-2.9-0.1.rc2.fc16.i686 (rawhide)
           Requires: llvm = 2.9-0.1.rc2.fc16
           Installed: llvm-2.9-0.2.rc1.fc16.i686 (@rawhide)
               llvm = 2.9-0.2.rc1.fc16
           Available: llvm-2.9-0.1.rc2.fc16.i686 (rawhide)
               llvm = 2.9-0.1.rc2.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
No such troubles

Additional info:
This same problem also means yum doesn't upgrade llvm (and friends) in Rawhide to the latest packages (since the latest version doesn't qualify as an upgrade for yum).
Comment 1 Michel Alexandre Salim 2011-08-02 11:26:15 EDT
That should have been 0.3.rc2, sorry. Fixed in 2.9-1.fc16 (should be in updates-testing soon) but not in Rawhide yet as the i686 build is for some reason always stalling.

Note You need to log in before you can comment on or make changes to this bug.