Bug 696103 - memcpy is wrongly used in readahead-collector
memcpy is wrongly used in readahead-collector
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: readahead (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 696096
  Show dependency treegraph
 
Reported: 2011-04-13 05:21 EDT by Felipe Contreras
Modified: 2011-04-20 10:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 10:01:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Contreras 2011-04-13 05:21:05 EDT
Description of problem:
See bug #696096 for why it's important that memcpy is properly used.

Version-Release number of selected component (if applicable):
1.5.6-1

How reproducible:
Each boot

Steps to Reproduce:
See bug #696096
  
Actual results:
readahead-collector crashes (fails the test)

Expected results:
readahead-collector doesn't crash

Additional info:
For some reason abrt is not reporting the crash, so I don't have the backtrace.
Comment 1 Felipe Contreras 2011-04-20 10:01:32 EDT
Looks like it was a false alarm; src == dst is not a problem.

Note You need to log in before you can comment on or make changes to this bug.