Bug 696114 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freeradius (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-13 06:34 EDT by Jóhann B. Guðmundsson
Modified: 2011-10-02 14:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: freeradius-2.1.11-7.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-02 14:14:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for radiusd (379 bytes, text/plain)
2011-04-13 06:34 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for radiusd socket (127 bytes, text/plain)
2011-04-13 06:36 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for raidusd with workaround (396 bytes, text/plain)
2011-07-04 03:57 EDT, Jóhann B. Guðmundsson
no flags Details
freeradius tmpfile (42 bytes, text/plain)
2011-07-04 04:37 EDT, Jóhann B. Guðmundsson
no flags Details
Patch that Introduce systemd unit file, drop SysV support to the spec file.. (2.31 KB, patch)
2011-07-04 04:39 EDT, Jóhann B. Guðmundsson
no flags Details | Diff

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-13 06:34:51 EDT
Created attachment 491709 [details]
Native systemd service file for radiusd

Description of problem:

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-04-13 06:36:02 EDT
Created attachment 491710 [details]
Native systemd service file for radiusd socket
Comment 2 Jóhann B. Guðmundsson 2011-04-13 06:41:45 EDT
As of freeradius 2.x it has supported configuration check thus I added that to the service file which will check for it upon start/restart and reload and respectfully refuse to re(start) and reload if an error is found. 

To test this copy the attached files to /lib/systemd/system and run 

systemctl daemon-reload

systemctl start/restart/reload/stop/status radiusd.service
Comment 3 Bill Nottingham 2011-04-26 13:35:18 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 5 John Dennis 2011-07-01 11:55:55 EDT
re comment #4

I've only done cursory examination of the systemd transition issues. I have not exercised and tested the proposed files (thank you for providing them). At the moment I believe my Redhat manager believes there are higher priority tasks. If this is a time critical issue please advise.
Comment 6 Jóhann B. Guðmundsson 2011-07-01 12:30:25 EDT
(In reply to comment #5)
> re comment #4
> 
> I've only done cursory examination of the systemd transition issues. I have not
> exercised and tested the proposed files (thank you for providing them). At the
> moment I believe my Redhat manager believes there are higher priority tasks. If
> this is a time critical issue please advise.

It would be good to get this done before alpha ( beginning of august ) as in packaging them to get them into the release and out for testing. 
( I can provide you with a patch against your spec file if needed ) 

Any issue that might crop up can then be fixed during the rest of the release development cycle.

You can test this by simply copy the attached files into /lib/systemd/system directory on F15+ 

then run 

systemctl daemon-reload 

To tell systemd to pickup and use the submitted file then run 

systemctl start/status/stop radiusd.service 

The socket file might be missing that is if it applies.. 

ListenStream=0.0.0.0:1812
ListenStream=[::]:1812
ListenStream=0.0.0.0:1813
ListenStream=[::]:1813

I did not get to test the socket well enough since radius was complaining that he did not own radiusd.sock
( Error: We do not own /var/run/radiusd/radiusd.sock )

Adding 

User=radiusd
Group=radiusd 

To the unit files changed nothing I have absolutely no idea what's going wrong there.
Comment 7 Jóhann B. Guðmundsson 2011-07-04 02:54:16 EDT
The authentication error might be a upstream bug.. 

http://freeradius.1045715.n5.nabble.com/ownership-change-td2777838.html
Comment 8 Jóhann B. Guðmundsson 2011-07-04 03:57:55 EDT
Created attachment 511131 [details]
Native systemd service file for raidusd with workaround

Added a workaround for the permission error to the unit file and removed the native radiusd socket file ( dont think we actually need that one ) 

Service now starts cleanly..

# systemctl status radiusd.service
radiusd.service - FreeRADIUS high performance RADIUS server.
	  Loaded: loaded (/lib/systemd/system/radiusd.service)
	  Active: active (running) since Mon, 04 Jul 2011 07:56:10 +0000; 1s ago
	 Process: 31580 ExecStart=/usr/sbin/radiusd -d /etc/raddb (code=exited, status=0/SUCCESS)
	 Process: 31578 ExecStartPre=/usr/sbin/radiusd -C (code=exited, status=0/SUCCESS)
	 Process: 31576 ExecStartPre=/bin/chown -R radiusd.radiusd /var/run/radiusd (code=exited, status=0/SUCCESS)
	Main PID: 31581 (radiusd)
	  CGroup: name=systemd:/system/radiusd.service
		  └ 31581 /usr/sbin/radiusd -d /etc/raddb

# netstat -pan | grep radiusd
udp        0      0 127.0.0.1:18120             0.0.0.0:*                               31581/radiusd       
udp        0      0 0.0.0.0:1812                0.0.0.0:*                               31581/radiusd       
udp        0      0 0.0.0.0:1813                0.0.0.0:*                               31581/radiusd       
udp        0      0 0.0.0.0:1814                0.0.0.0:*                               31581/radiusd       
unix  2      [ ACC ]     STREAM     LISTENING     93628073 31581/radiusd       /var/run/radiusd/radiusd.sock
Comment 9 Jóhann B. Guðmundsson 2011-07-04 04:37:59 EDT
Created attachment 511138 [details]
freeradius tmpfile
Comment 10 Jóhann B. Guðmundsson 2011-07-04 04:39:02 EDT
Created attachment 511139 [details]
Patch that Introduce systemd unit file, drop SysV support to the spec file..
Comment 11 Fedora Update System 2011-09-08 14:57:23 EDT
freeradius-2.1.11-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/freeradius-2.1.11-5.fc16
Comment 12 Fedora Update System 2011-09-08 16:50:41 EDT
Package freeradius-2.1.11-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeradius-2.1.11-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/freeradius-2.1.11-5.fc16
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-09-09 12:33:01 EDT
freeradius-2.1.11-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/freeradius-2.1.11-6.fc16
Comment 14 Fedora Update System 2011-09-21 17:08:56 EDT
freeradius-2.1.11-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/freeradius-2.1.11-7.fc16
Comment 15 Fedora Update System 2011-10-02 14:14:03 EDT
freeradius-2.1.11-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.