This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 696262 - pool with "unlimited" quantity shows as -1 in contract selection dialog
pool with "unlimited" quantity shows as -1 in contract selection dialog
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-04-13 13:55 EDT by John Sefler
Modified: 2011-12-06 12:13 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:13:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
-1 quantity avail should read as "unlimited" (25.86 KB, image/png)
2011-04-13 13:55 EDT, John Sefler
no flags Details
fix for unlimited in Contract Selection dialog (24.51 KB, image/png)
2011-07-12 17:06 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-04-13 13:55:05 EDT
Created attachment 491841 [details]
-1 quantity avail should read as "unlimited"

Description of problem:
When subscribing to a pool through the gui for which one of the contracts has an unlimited quantity, it shows up as -1 in the contract selection dialog

See attached screenshot

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-server tmp]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.95.8-1.el6.x86_64

This bug is found against rhel61, but is being opened against rhel57


How reproducible:


Steps to Reproduce:
1. register as the qa@redhat.com user against the production candlepin
2. use the gui to subscribe to the Red Hat Employee Subscription
3. in the contract selection dialog you will see the attached screenshot

Additional info:
# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a85f9812ede00af012edf01c88c5ce0
Quantity:          	18                       
Expires:           	2011-10-04               


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a85f9812ede00af012edf01c89f5cf9
Quantity:          	9994                     
Expires:           	2011-10-07               


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a85f9812ede00af012edf01c8a65d04
Quantity:          	unlimited                
Expires:           	2011-10-07              



Actual results:
-1

Expected results:
Unlimited
Comment 1 Chris Duryee 2011-04-13 15:30:48 EDT
Fixed on master branch in 129ad420940e72703a50b4f0c5674816a5c28dce, version
0.96.2
Comment 2 John Sefler 2011-07-12 17:06:34 EDT
Created attachment 512516 [details]
fix for unlimited in Contract Selection dialog

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.3-1.git.33.8f93d7f.el6.x86_64
Comment 4 errata-xmlrpc 2011-12-06 12:13:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.