Bug 696314 - request for upgrade to version 1.9.7
Summary: request for upgrade to version 1.9.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jack-audio-connection-kit
Version: 14
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-13 19:53 UTC by Fernando Lopez-Lezcano
Modified: 2011-05-20 20:54 UTC (History)
3 users (show)

Fixed In Version: jack-audio-connection-kit-1.9.7-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-20 20:54:46 UTC


Attachments (Terms of Use)

Description Fernando Lopez-Lezcano 2011-04-13 19:53:21 UTC
Description of problem:

It would be nice to upgrade jack to the latest version (1.9.7 as of this writing). It fixes bugs and adds some recent API functions that are needed to build the latest alpha versions of Ardour 3. 

Here's part of the announcement:

----
What is new:

- Sync JackAlsaDriver::alsa_driver_check_card_type with JACK1 backend. 
- Correct JackServer::Open to avoid a race when control API is used on OSX. 
- Improve backend error handling: fatal error returned by Read/Write now cause a Process failure (so a thread exit for blocking backends). 
- Recoverable ones (XRuns..) are now treated internally in ALSA, FreeBob and FFADO backends. 
- In jackdmp.cpp, jackctl_setup_signals moved before jackctl_server_start. 
- Correct symbols export in backends on OSX. ALSA backend : suspend/resume handling. 
- Correct dummy driver. 
- Adrian Knoth jack_lsp patch. 
- Remove JackPortIsActive flag. 
- New latency API implementation. 
- ComputeTotalLatencies now a client/server call. 
- Add latent test client for latency API. 
- Also print playback and capture latency in jack_lsp. 
- jack_client_has_session_callback implementation. 
- Check requested buffer size and limit to 1..8192 - avoids weird behaviour caused by jack_bufsize foobar.  
- jack_port_type_get_buffer_size implementation. 
- Stop using alloca and allocate buffer on the heap for alsa_io. 
- Rename jdelay to jack_iodelay as per Fons' request. 
- Call buffer size callback in activate (actually this is done on client side in the RT thread Init method).  
- Add jack_midi_dump client. Synchronize net JACK1 with JACK1 version. 
- Synchronize jack_connect/jack_disconnect with JACK1 version. 
- Correct JackNetMaster::SetBufferSize. 
- Use jack_default_audio_sample_t instead of float consistently, fix ticket #201. -X now allows to add several slave backends, add -I to load several internal clients. 
- Rework internal slave driver management, JackServerGlobals now handle same parameters as jackdmp. 
- Correct JackEngine::NotifyGraphReorder, update JackDebugClient with latest API. 
- Devin Anderson server-ctl-proposal branch merged on trunk: improved control API, slave backend reworked. 
- Implement renaming in JackDriver::Open to avoid name collision (thanks Devin Anderson). 
- Correct alsa_driver_restart (thanks Devin Anderson). 
- Correction of jack_connect/jack_disconnect: use of jack_activate and volatile keyword for thread shared variable.  
- Correction of JackNetOneDriver for latest CELT API. 
- Synchronize JackWeakAPI.cpp with new APIs. 
----

So, tons of fixes and worthwhile upgrading...


Version-Release number of selected component (if applicable):

jack-audio-connection-kit-1.9.6

Comment 1 Orcan Ogetbil 2011-04-16 17:21:53 UTC
Hi, thanks for the request. At this point I am waiting for the resolution of bug 684392 before making the update. Meanwhile, could you also provide me the port names patch if there is need?

Comment 2 Fedora Update System 2011-05-07 03:08:58 UTC
jack-audio-connection-kit-1.9.7-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/jack-audio-connection-kit-1.9.7-2.fc14

Comment 3 Fedora Update System 2011-05-07 19:56:32 UTC
Package jack-audio-connection-kit-1.9.7-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jack-audio-connection-kit-1.9.7-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/jack-audio-connection-kit-1.9.7-2.fc14
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-05-20 20:54:41 UTC
jack-audio-connection-kit-1.9.7-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.