Bug 696379 - Cannot enable Korean Input Method.
Cannot enable Korean Input Method.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-13 19:07 EDT by sangu
Modified: 2011-04-22 23:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110408-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-22 23:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2011-04-13 19:07:12 EDT
Description of problem:
connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Timeout was reached

Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/panel.py", line 511, in __im_menu_item_activate_cb
    self.__focus_ic.set_engine(engine)
  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 238, in set_engine
    return self.__context.SetEngine(engine.name)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.Failed: Timeout was reached

Local variables in innermost frame:
byte_arrays: False
self: <dbus.connection.Connection object at 0x1e86110>
args: (dbus.String(u'hangul'),)
utf8_strings: False
bus_name: 'org.freedesktop.IBus'
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_4')
timeout: -1.0
signature: u's'
dbus_interface: 'org.freedesktop.IBus.InputContext'
message: <dbus.lowlevel.MethodCallMessage object at 0x2016d80>
method: 'SetEngine'



Version-Release number of selected component (if applicable):
ibus-1.3.99.20110228-6.fc15.x86_64

How reproducible:

After reestart ibus, Korean Input Mothd works.
And reboot computer, Sometimes this issue happen.

Steps to Reproduce:
1. login to gnome
2. Launch gedit
3. Enable Korean Input Method (Click Korean in ibus tray)
  
Actual results:


Expected results:


Additional info:

See also bug 522047, comment 30 , this issue happean, again.
Comment 1 Jens Petersen 2011-04-14 02:11:46 EDT
Not sure how to reproduce this: works for me.
Comment 2 fujiwara 2011-04-19 01:41:08 EDT
I cannot reproduce your problem.
Are you able to reproduce your problem with ibus-1.3.99.20110408-1 ?
http://koji.fedoraproject.org/koji/buildinfo?buildID=239582

I'll integrate it in f15.
Comment 3 sangu 2011-04-19 23:09:19 EDT
Fixed in 1.3.99.20110408-1.fc15.x86_64.
Thanks!
Comment 4 fujiwara 2011-04-19 23:20:53 EDT
Nice to see the good result.
Maybe an upstream patch or caps feature of surrounding-text.
Comment 5 Fedora Update System 2011-04-20 00:32:13 EDT
ibus-1.3.99.20110408-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110408-2.fc15
Comment 6 Fedora Update System 2011-04-20 23:00:11 EDT
Package ibus-1.3.99.20110408-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110408-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110408-2.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-04-22 23:57:18 EDT
ibus-1.3.99.20110408-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.