This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 696408 - If an entry with a mixed case RDN is turned to be a tombstone, it fails to assemble DN from entryrdn
If an entry with a mixed case RDN is turned to be a tombstone, it fails to as...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.1
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
: screened
Depends On: 696407
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-13 21:47 EDT by Noriko Hosoi
Modified: 2015-01-04 18:47 EST (History)
5 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.8.2-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 696407
Environment:
Last Closed: 2011-05-19 08:43:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Noriko Hosoi 2011-04-13 21:47:28 EDT
+++ This bug was initially created as a clone of Bug #696407 +++

Description of problem:
The symptom is if an RDN contains upper case characters, and the entry is deleted (== turned into a tombstone entry), the entry cannot be found any more.

Plus these messages are logged in the error log again and again...
[13/Apr/2011:13:13:45 -0700] _entry_set_tombstone_rdn - Failed to convert DN uid=jmcFarla to RDN
[13/Apr/2011:13:13:45 -0700] id2entry - str2entry returned NULL for id 30, string="rdn"

This bug was introduced with the bug fix for the bug 684996:
Bug 684996 - Exported tombstone cannot be imported correctly.

--- Additional comment from nhosoi@redhat.com on 2011-04-13 21:45:31 EDT ---

Created attachment 491934 [details]
git patch file (master)

Description: When an entry is turned to be a tombstone, the RDN
part is replaced with this unusual format:
    "nsuniqueid=9a63a581-...-ca8fe9f7,uid=tuser1"
A helper function slapi_rdn_replace_rdn was introduced to support
the replace task, in which function, normalized rdn field "nrdn"
was supposed to have lowered case RDN, but it was not.
This patch fixes it.
Comment 1 RHEL Product and Program Management 2011-04-14 02:00:25 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Chandrasekar Kannan 2011-04-17 19:35:22 EDT
Please add steps to reproduce
Comment 7 errata-xmlrpc 2011-05-19 08:43:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0533.html

Note You need to log in before you can comment on or make changes to this bug.