Bug 696437 - Python client: --dstdir of po pull does not work
Python client: --dstdir of po pull does not work
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
1.3-alpha-1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 00:35 EDT by Ding-Yi Chen
Modified: 2011-10-28 03:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2011-04-14 00:35:41 EDT
Description of problem:
Without '--dstdir', "zanata po pull" works well.
However, when given zanata po pull --dstdir=/tmp 
it throws error messages.

Version-Release number of selected component (if applicable):
zanata-python-client-1.2.2
Server: 1.2 (20110307-0010)

How reproducible:
Always

Steps to Reproduce:
1. Assume zanata.ini zanata.xml are properly configured.
2. zanata po pull --dstdir=/tmp --url=<serverUrl>
3.
  
Actual results:
Traceback (most recent call last):
  File "/tmp/zanata-python-client/zanata", line 26, in <module>
    client.run()
  File "/tmp/zanata-python-client/zanataclient/zanata.py", line 1436, in run
    self._pull_pofile(command_args)
  File "/tmp/zanata-python-client/zanataclient/zanata.py", line 850, in _pull_pofile
    pofile = os.path.join(outpath, item+'.po')
UnboundLocalError: local variable 'outpath' referenced before assignment

Expected results:
Po files are pulled to /tmp

Additional info:
Comment 1 James Ni 2011-04-18 23:35:17 EDT
I have fix this issue in commit 7f0f3d0d1014adb1b57b, but please verify this issue with commit
0e90977fe121820a6ca8 of devel branch of zanataclient on github,since i merge some changes from server.
Comment 2 Ding-Yi Chen 2011-04-19 22:12:32 EDT
Test passed with commit b1df3d6c9a5a58ab65c13b0366a24b1a2b31c988

Note You need to log in before you can comment on or make changes to this bug.