Bug 69644 - Cannot NFS install with Intel 82562 onboard NIC
Summary: Cannot NFS install with Intel 82562 onboard NIC
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-24 01:31 UTC by Roderick Constance
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 18:55:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roderick Constance 2002-07-24 01:31:39 UTC
Description of Problem:

The onboard NIC (Intel 82562) on this Tyan S2099-based system is not recognised
during the RH73 install.  Therefore I cannot install the OS via NFS.  The device
ID (8086:103a (rev. 81)) is not listed in modules/pcitable.

Although, I can install the OS via CD and load either the eepro100 or the e100
modules successfully.

Version-Release number of selected component (if applicable):
RedHat 7.3 installer

How Reproducible:
Always

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
No option for NFS install

Expected Results:
NFS install option

Additional Information:

Comment 1 Jeremy Katz 2002-07-26 00:23:21 UTC
Is this an Intel i845 board?

Comment 2 Roderick Constance 2002-07-26 00:41:00 UTC
Yes, this is a i845E board.  But the particular board I was testing only had the
10/100 onboard (82562), and not the gigabit (82540).  And as I mentioned before,
the shipped e100 as well as the eepro100 worked on the 82562.  But I think the
82540 would present problems, since I didn't see an entry in the
drivers/pci/pci.ids table.  But I can't confirm this, nor do I have a device ID
for the 82540.

Comment 3 Michael Fulbright 2002-08-14 19:50:09 UTC
Reassigning to kernel component.

Comment 4 Need Real Name 2002-09-27 21:00:00 UTC
I'm running the Tyan S2099 GNN (dual network) board. I checked the output 
of /sbin/lspci and here are the settings I get and added to my pcitables (the 
second is the GigE controller that Intel shows as compatible with the 82542, 
82543, 82544):

0x8086 0x1039 "eepro100" "Intel Corp.|82562 Integrated Ethernet Controller"

0x8086 0x100e "e1000" "Intel Corp.|82540 Gigabit Ethernet Controller"

I have yet to verify whether these entries work with the default RH7.3 drivers.

Comment 5 Arjan van de Ven 2003-06-07 18:55:01 UTC
current errata kernels have a newer driver with more hw support


Note You need to log in before you can comment on or make changes to this bug.