Bug 696490 - error reading information on service sssd: No such file or directory
error reading information on service sssd: No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 03:03 EDT by Jóhann B. Guðmundsson
Modified: 2011-08-01 22:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: authconfig-6.1.15-1.fc16
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-22 07:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-14 03:03:55 EDT
Description of problem:

When running setup and setup ldap auth this what seems to be cosmetic error appears.

# setup
Note: Forwarding request to 'systemctl disable ypbind.service'.
error reading information on service sssd: No such file or directory <---
Note: Forwarding request to 'systemctl enable sssd.service'.
ln -s '/lib/systemd/system/sssd.service' '/etc/systemd/system/multi-user.target.wants/sssd.service'
Redirecting to /bin/systemctl  start sssd.service

Running ldap 

Version-Release number of selected component (if applicable):

setuptool-1.19.11-3.fc15

How reproducible:

always

Steps to Reproduce:
1.run setup
2.select and setup ldap aut
3.
  
Actual results:

error reading information on service sssd: No such file or directory

Expected results:

No error

Additional info:

You guys should consider start looking at making setup use native systemd commands as opposed to be using service $foo and chkconfig $foo which seems to be what you are calling now as in service start/stop $foo == systemctl start/stop $foo.service chkconfig on/off $foo == systemctl enable/disable $foo.service 

As an example service sssd start in systemd world becomes systemctl start sssd.service and service sssd stop becomes systemctl stop sssd.service and chkconfig sssd on becomes systemctl enable sssd.service and chkconfig sssd off become systemctl disable sssd.service
Comment 1 Michal Hlavinka 2011-04-14 03:26:35 EDT
setuptool is just system-config-* launcher reassigning component
Comment 2 Tomas Mraz 2011-04-14 04:31:00 EDT
Patches welcome.
Comment 3 Jóhann B. Guðmundsson 2011-04-14 04:42:09 EDT
Note that sssd has been currently resides in updates testing ( F15 )with native systemd service file https://admin.fedoraproject.org/updates/sssd-1.5.5-2.fc15

Which will take precedence over the old sysv init scripts..
Comment 4 Tomas Mraz 2011-04-14 04:51:18 EDT
I thought that the chkconfig and service commands will be supported for now as a compatibility wrapper.
Comment 5 Jóhann B. Guðmundsson 2011-04-14 05:38:03 EDT
They do up to a certain extent

Service $foo $bar should have one to one mapping to systemctl $bar $foo.service 

But I doubt chkconfig has other than on/off service to systemctl enable/disable since runlevel in the traditional sense dont exist in systemd.

And this "error reading information on service sssd: No such file or directory" is probably because it's trying to do something with /etc/init.d/sssd which no longer exist and no longer is needed since there is a native systemd service file and whatever changes you do to a sysv file in /etc/init.d/ wont be picked up by systemd once systemd has it's own native service file for systemd.
Comment 6 Tomas Mraz 2011-07-22 07:34:54 EDT
Authconfig now properly supports both old sysv utilities and systemctl, which is preferred if exists.
Comment 7 Fedora Update System 2011-07-22 07:46:30 EDT
authconfig-6.1.15-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/authconfig-6.1.15-1.fc15
Comment 8 Fedora Update System 2011-08-01 22:02:47 EDT
authconfig-6.1.15-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.