Bug 69652 - KDE displaying items not in applications.menu
KDE displaying items not in applications.menu
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-24 00:36 EDT by Havoc Pennington
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-04 12:18:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-07-24 00:36:56 EDT
KDE is merging in menu items from somewhere other than applications.menu. 
These all need to be eliminated.

Examples: Tons of subfolders under Preferences, Applications/Development/Utilities 
toplevel folders.

Nothing should be pulled in from outside of /var/lib/menu/kde - if you 
need something from elsewhere, ask me to add it to applications.menu in 
redhat-menus.
Comment 1 Ngo Than 2002-07-24 16:20:31 EDT
KDE still merge items from /etc/X11/applnk and /usr/share/applnk. All current
KDE packages have desktop files in /usr/share/applications. If you see
subfolders under Applications/Development/Utilities, you still have old packages
which contain old desktop files.

The Preferences folder has following subfolders:
  Databases
  FileBrowsing
  Information
  LookNFeel
  Network
  Peripherals
  Personalization
  PowerControl
  Sound
  System
  WebBrowsing

If you take a look under /usr/share/apps/kcontrol/applnk/Preferences
you will see these subfolders.

They contains over 90 subprograms for kcontrol, which can only start in KDE
enviroment (kcontrol).

It could be fine if you could add it into redhat menus. Thanks

Comment 2 Havoc Pennington 2002-07-24 17:55:21 EDT
KDE should not be merging from /etc/X11/applnk, because desktop-menu-tool
already did that merge. So KDE is re-merging and doing it incorrectly.

Go ahead and remove this merging, and the preferences merging, so we can see
what the real situation is and not get confused. Then we'll add the prefs and so
forth to redhat-menus.
Comment 3 Ngo Than 2002-08-04 12:18:23 EDT
i removed merging old kde menus in kdebase-3.0.2-7.1 or new
Comment 4 Jay Turner 2002-09-03 12:50:57 EDT
Fixes look good with kdebase-3.0.3-10.

Note You need to log in before you can comment on or make changes to this bug.