Bug 69655 - segfault upon running in virtual console
Summary: segfault upon running in virtual console
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-24 06:16 UTC by Michael Schwendt
Modified: 2015-01-07 23:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-24 06:25:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2002-07-24 06:16:29 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
Running up2date in virtual console gives: 
 
No interactive mode available 
Please specify either -l, -u, --nox, or package names as command line arguments. 
Segmentation fault 
 
 
Version-Release number of selected component (if applicable): 
Limbo installed from scratch with following packages updated: 
 * rhnlib-0.8-11 
 * up2date-2.9.20-7.x.9 
 * up2date-gnome-2.9.20-7.x.9 
 
How reproducible: 
Always 
 
Step to reproduce: 
1. CTRL+ALT+F1 
2. up2date

Comment 1 Adrian Likins 2002-07-24 06:25:01 UTC
There seems to be something funky happening anytime a non
supported set of arguments is giving. 

up2date --safasdfadfasdf

will segfault as well. Havent dug very deep into the cause
yet, since it doesnt seem to break anything in normal
useage, and is probabaly down in python-popt, which
is scheduled for removal.

on the radar, but a low priority at the moment...


Comment 2 Michael Schwendt 2002-08-06 08:20:08 UTC
Apparently, this has been fixed (2.9.33-7.x.9). Tested with Limbo beta2 and
first huge bunch of upgrades applied.



Note You need to log in before you can comment on or make changes to this bug.