Bug 696611 - Systemd Service files
Summary: Systemd Service files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nut
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 704197
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-14 12:32 UTC by Jóhann B. Guðmundsson
Modified: 2011-07-25 14:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-25 14:04:08 UTC


Attachments (Terms of Use)
native systemd service files for upsd (470 bytes, application/x-gzip)
2011-04-14 12:32 UTC, Jóhann B. Guðmundsson
no flags Details
upsd-monitor.service (249 bytes, text/plain)
2011-04-14 14:17 UTC, Jóhann B. Guðmundsson
no flags Details
upsd service correct one ( no longer is needed nor should be used masters/slave ) (311 bytes, text/plain)
2011-04-14 14:19 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-04-14 12:32:57 UTC
Created attachment 492081 [details]
native systemd service files for upsd

Description of problem:

As mentioned on -devel. 

Split into three service files 

Dump it into /lib/systemd/system/ directory 

run systemctl daemon-reload 

systemctl start upsd-master.service will start the master server and upsd-driver.service 

systemctl start upsd-slave.service will start the slave server 

The upsd-driver.service might need some tweaking since I dont have an ups handy

Also I would like to point out that hal is being deprecated ( installing nut pulled in bunch of hal packages )

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Hlavinka 2011-04-14 12:57:37 UTC
As I said in devel list, any change that would break existing configuration is a no go.

> Also I would like to point out that hal is being deprecated
> ( installing nut pulled in bunch of hal packages )

it should be required only by nut-hal sub package, I'll look at it.

Comment 2 Jóhann B. Guðmundsson 2011-04-14 14:17:52 UTC
Created attachment 492118 [details]
upsd-monitor.service

Comment 3 Jóhann B. Guðmundsson 2011-04-14 14:19:05 UTC
Created attachment 492119 [details]
upsd service correct one ( no longer is needed nor should be used masters/slave )

Comment 4 Bill Nottingham 2011-04-26 17:35:25 UTC
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy

Comment 5 Michal Hlavinka 2011-04-29 11:27:07 UTC
We've discussed this with upstream and they agree with upsd&upsdrvctl / upsmon split. So we'll handle this in F16 after we discuss remaining details.

Comment 6 Michal Hlavinka 2011-07-25 14:04:08 UTC
should be working fine, except the "depends on" systemd bug


Note You need to log in before you can comment on or make changes to this bug.