Bug 69662 - Symlinks made in %post, should be in %install
Summary: Symlinks made in %post, should be in %install
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: nvi-m17n   
(Show other bugs)
Version: limbo
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nakai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-24 09:14 UTC by Jos Vos
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 07:44:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2002-07-24 09:14:39 UTC
The nvi-* package contains a %post scripts that creates symlinks (using the
$RPM_BUILD_ROOT shell variable (!), which evaluates to the empty string - I hope
- during binary package installation). Instead of this, the symlinks should be
created in the %install part of the rpm so that they belong - administratively -
to the package.

Comment 1 Nakai 2002-08-14 08:59:10 UTC
$RPM_BUILD_ROOTs in %preun, %post are removed
(nvi-m17n-1.79-20011024.6) but
putting them in %install is impossible because it creates
2 packages, with-canna and no-canna.



Note You need to log in before you can comment on or make changes to this bug.