Bug 696647 - ORA-01002 "fetch out of sequence" errors with Oracle database
ORA-01002 "fetch out of sequence" errors with Oracle database
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Database (Show other bugs)
unspecified
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-14 10:19 EDT by Mike Foley
Modified: 2011-04-21 14:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-21 14:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serverlogfile (59.92 KB, application/octet-stream)
2011-04-14 10:19 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-04-14 10:19:09 EDT
Created attachment 492120 [details]
serverlogfile

Description of problem:
ORA-01002 errors with Oracle database

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.  Install RHQ with Oracle 11 database, doing all Oracle configuration stuff
2.  log in, dashboard, inventory, view some resources
3.
  
Actual results:
Caused by: java.sql.SQLException: ORA-01002: fetch out of sequence

	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:440)
	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:396)
	at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:837)
	at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:445)
	at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:191)
	at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:523)
	at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:207)
	at oracle.jdbc.driver.T4CPreparedStatement.fetch(T4CPreparedStatement.java:1084)
	at oracle.jdbc.driver.OracleResultSetImpl.close_or_fetch_from_next(OracleResultSetImpl.java:359)
	at oracle.jdbc.driver.OracleResultSetImpl.next(OracleResultSetImpl.java:263)
	at org.jboss.resource.adapter.jdbc.WrappedResultSet.next(WrappedResultSet.java:1196)
	at org.hibernate.loader.Loader.doQuery(Loader.java:697)
	at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Loader.java:236)
	at org.hibernate.loader.Loader.doList(Loader.java:2213)
	... 164 more


Expected results:
absence of oracle errors in the server log file

Additional info:
Comment 2 Charles Crouch 2011-04-18 20:09:22 EDT
Mike, can you track this down to one particular request in the UI?
Comment 3 Mike Foley 2011-04-21 14:12:59 EDT
I retested this Oracle 10G Express with RHQ CR1 ... and have not seen the ORA-01002 issues ...which were quite prevalent before.  This was a new installation of Oracle, and perhaps I followed the post-installation steps more closely which resulted in the correct behavior and the issue not manifesting.

Note You need to log in before you can comment on or make changes to this bug.