Bug 696680 - [abrt] claws-mail-3.7.9-2.fc14: _int_malloc: Process /usr/bin/claws-mail was killed by signal 11 (SIGSEGV)
Summary: [abrt] claws-mail-3.7.9-2.fc14: _int_malloc: Process /usr/bin/claws-mail was ...
Keywords:
Status: CLOSED DUPLICATE of bug 759143
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b180c0754e709dae2becffef470...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-14 15:44 UTC by David Kovalsky
Modified: 2014-03-31 23:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-30 13:08:45 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (115.89 KB, text/plain)
2011-04-14 15:44 UTC, David Kovalsky
no flags Details

Description David Kovalsky 2011-04-14 15:44:08 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 118669 bytes
cmdline: claws-mail
component: claws-mail
Attached file: coredump, 217956352 bytes
crash_function: _int_malloc
executable: /usr/bin/claws-mail
kernel: 2.6.35.12-88.fc14.x86_64
package: claws-mail-3.7.9-2.fc14
rating: 4
reason: Process /usr/bin/claws-mail was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1302795555
uid: 10625

How to reproduce
-----
I had claws-mail open whole day during which I ran around with my notebook changing network connectivity to wired (dock station) and different wifis, back and forth. After I docked the notebook I read a couple of emails and after clicking NEW to send one, claws-crashed. 

I couldn't reproduce it when I tried again

Comment 1 David Kovalsky 2011-04-14 15:44:11 UTC
Created attachment 492155 [details]
File: backtrace

Comment 2 Michael Schwendt 2011-04-14 19:12:17 UTC
step #36 in the backtrace is compose.c in Claws Mail
#35 to #4 is in GTK and GLib
#3 to #1 is malloc.c in glibc where it crashes

Just from the looks of it, your machine went unstable. Suspend/Resume involved?

| #0  0x00000031ddc77b46 in _int_malloc (av=0x31ddf971c0,
| bytes=<value optimized out>) at malloc.c:4538
| 4538		unlink(victim, bck, fwd);

Comment 3 David Kovalsky 2011-04-15 08:55:37 UTC
Hi Michael, 

thanks for the quick response.

I'm pretty confident I've rebooted in the morning and haven't suspended during the day. Uptime on my machine is around 12hours, that makes me even more confident. 

I did a `yum update' during the day though, below is the list of packages update from updates-testing. Perhaps that may have destabilized the system (?)

Nothing glibc/glib related, though several pygtk-* packages have been upgraded. Maybe those trigered it? I don't recall how long claws was running and if I restarted it after the update.

Apr 14 16:25:10 Updated: 1:qt-4.7.2-8.fc14.x86_64
Apr 14 16:25:11 Updated: exiv2-libs-0.21.1-1.fc14.x86_64
Apr 14 16:25:12 Updated: libtiff-3.9.5-1.fc14.x86_64
Apr 14 16:25:17 Installed: 1:qt-x11-4.7.2-8.fc14.x86_64
Apr 14 16:25:18 Updated: phonon-4.5.0-2.fc14.x86_64
Apr 14 16:25:20 Updated: strigi-libs-0.7.2-5.fc14.1.x86_64
Apr 14 16:25:22 Updated: 1:qt-webkit-4.7.2-8.fc14.x86_64
Apr 14 16:25:23 Updated: nss-sysinit-3.12.9-10.fc14.x86_64
Apr 14 16:25:24 Updated: nss-3.12.9-10.fc14.x86_64
Apr 14 16:25:25 Updated: ffmpeg-libs-0.6.2-1.fc14.x86_64
Apr 14 16:25:36 Updated: vlc-core-1.1.9-1.fc14.x86_64
Apr 14 16:25:39 Updated: pygtk2-2.17.0-8.fc14.x86_64
Apr 14 16:25:40 Updated: tigervnc-license-1.0.90-0.25.20100813svn4123.fc14.noarch
Apr 14 16:25:41 Updated: tigervnc-server-minimal-1.0.90-0.25.20100813svn4123.fc14.x86_64
Apr 14 16:25:42 Updated: exiv2-0.21.1-1.fc14.x86_64
Apr 14 16:25:44 Updated: ufraw-common-0.18-2.fc14.1.x86_64
Apr 14 16:25:48 Updated: ufraw-0.18-2.fc14.1.x86_64
Apr 14 16:25:49 Updated: 6:kdelibs-common-4.6.2-1.fc14.x86_64
Apr 14 16:26:02 Updated: 6:kdelibs-4.6.2-1.fc14.x86_64
Apr 14 16:26:05 Updated: kdepimlibs-4.6.2-1.fc14.x86_64
Apr 14 16:26:06 Updated: kdebase-runtime-flags-4.6.2-1.fc14.noarch
Apr 14 16:26:13 Updated: kdebase-runtime-4.6.2-1.fc14.x86_64
Apr 14 16:26:15 Updated: kdebase-runtime-libs-4.6.2-1.fc14.x86_64
Apr 14 16:26:19 Updated: 6:kdebase-4.6.2-1.fc14.x86_64
Apr 14 16:26:20 Updated: 6:kdebase-libs-4.6.2-1.fc14.x86_64
Apr 14 16:26:20 Updated: 6:kdeutils-minimal-libs-4.6.2-1.fc14.x86_64
Apr 14 16:26:23 Updated: 6:kdeutils-minimal-4.6.2-1.fc14.x86_64
Apr 14 16:26:25 Updated: kdepimlibs-akonadi-4.6.2-1.fc14.x86_64
Apr 14 16:26:28 Updated: 7:kdegraphics-libs-4.6.2-1.fc14.x86_64
Apr 14 16:26:29 Updated: ksysguardd-4.6.2-2.fc14.x86_64
Apr 14 16:26:31 Updated: kdebase-workspace-libs-4.6.2-2.fc14.x86_64
Apr 14 16:26:39 Updated: kdebase-workspace-4.6.2-2.fc14.x86_64
Apr 14 16:26:40 Updated: 7:kio_msits-4.6.2-1.fc14.x86_64
Apr 14 16:26:41 Updated: pygtk2-codegen-2.17.0-8.fc14.x86_64
Apr 14 16:26:45 Updated: pygtk2-doc-2.17.0-8.fc14.noarch
Apr 14 16:26:49 Updated: 7:kdegraphics-4.6.2-1.fc14.x86_64
Apr 14 16:26:51 Updated: geeqie-1.0-9.fc14.1.x86_64
Apr 14 16:26:53 Updated: tigervnc-server-1.0.90-0.25.20100813svn4123.fc14.x86_64
Apr 14 16:27:02 Updated: tigervnc-1.0.90-0.25.20100813svn4123.fc14.x86_64
Apr 14 16:27:03 Updated: pygtk2-libglade-2.17.0-8.fc14.x86_64
Apr 14 16:27:05 Updated: vlc-1.1.9-1.fc14.x86_64
Apr 14 16:27:06 Updated: vlc-extras-1.1.9-1.fc14.x86_64
Apr 14 16:27:08 Updated: ffmpeg-0.6.2-1.fc14.x86_64
Apr 14 16:27:09 Updated: nss-tools-3.12.9-10.fc14.x86_64
Apr 14 16:27:10 Updated: 1:qt-config-4.7.2-8.fc14.x86_64
Apr 14 16:27:20 Updated: 1:qt-devel-4.7.2-8.fc14.x86_64
Apr 14 16:27:24 Updated: gthumb-2.12.2-1.fc14.2.x86_64
Apr 14 16:27:25 Updated: 1:qt-mysql-4.7.2-8.fc14.x86_64
Apr 14 16:27:28 Updated: less-436-11.fc14.x86_64
Apr 14 16:27:29 Updated: python-ethtool-0.7-2.fc14.x86_64
Apr 14 16:27:30 Updated: pygtk2-devel-2.17.0-8.fc14.x86_64
Apr 14 16:27:32 Updated: phonon-debuginfo-4.5.0-2.fc14.x86_64
Apr 14 16:27:33 Updated: python-ethtool-debuginfo-0.7-2.fc14.x86_64
Apr 14 16:29:01 Updated: 1:qt-debuginfo-4.7.2-8.fc14.x86_64
Apr 14 16:29:12 Updated: nss-debuginfo-3.12.9-10.fc14.x86_64
Apr 14 16:29:16 Updated: 1:qt-4.7.2-8.fc14.i686
Apr 14 16:29:17 Updated: libtiff-3.9.5-1.fc14.i686
Apr 14 16:29:24 Updated: 1:qt-x11-4.7.2-8.fc14.i686
Apr 14 16:29:25 Updated: phonon-4.5.0-2.fc14.i686
Apr 14 16:29:27 Updated: 1:qt-webkit-4.7.2-8.fc14.i686
Apr 14 16:29:29 Updated: nss-3.12.9-10.fc14.i686
Apr 14 16:30:02 Erased: qt-designer-plugin-phonon

Comment 4 abrt-bot 2012-03-30 13:08:45 UTC
Backtrace analysis found this bug to be similar to bug #759143, closing as duplicate.

Bugs which were found to be similar to this bug: 
  DeviceKit-disks: bug #579968
  claws-mail: bug #749177, bug #789636
  evince: bug #615380
  evolution: bug #744469
  evolution-data-server: bug #607960, bug #799718
  evolution-exchange: bug #669649
  gnome-shell: bug #759143, bug #781780
  gvfs: bug #571349
  pcmanfm: bug #789628
  rhythmbox: bug #681163, bug #709834, bug #748661
  xfce4-sensors-plugin: bug #772409

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 759143 ***


Note You need to log in before you can comment on or make changes to this bug.