Bug 69670 - build srpms in HP-UX:patch file shows only file name not full path
build srpms in HP-UX:patch file shows only file name not full path
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.3
parisc11 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-24 07:41 EDT by Marko Harjula
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-24 07:41:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Harjula 2002-07-24 07:41:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020722

Description of problem:
Platform:parisc2.2 OS:HP-UX 11.11
build srpms in HP-UX .. 
ie linux patch command when build srpms
patch -options .patchname < /full/path/file.patch
and hp version
patch -options .patchname < file.patch

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.build rpm (4.0.4) to hp-ux 11.11 (and used prefix to i.e /opt/rpm )
2.create directories and configure rpm
3.try rpm --rebuild any gnu software
	

Actual Results:  
patch file not found ( missing full path to patch file)
"patch -options .patchname < file.patch"


Expected Results:  
"patch -options .patchname < /full/path/file.patch"

Additional info:

Only used --prefix when build rpm itself (and no errors in build time).
patch command is gnu version ( because hp version not work ).
When removed patchs from spec file, no errors anymore.
Comment 1 Jeff Johnson 2002-07-24 08:58:35 EDT
The sources/patches used in a build must be located
in the directory configured in the %{_sourcedir} macro,
and the full path (i.e. the concatenation of the the
expansion of %{_sourcedir} and the basename from
the Patch: tag) will be used by the %patch macro.

Note You need to log in before you can comment on or make changes to this bug.