Bug 696740 - Resource tree not always expanding in detail view.
Resource tree not always expanding in detail view.
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta2
All All
medium Severity urgent (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-14 14:37 EDT by Jay Shaughnessy
Modified: 2011-10-04 15:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:10:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2011-04-14 14:37:40 EDT
There are time when navigating to a resource detail view that the tree does not expand.  It is not consistent
Comment 1 Jay Shaughnessy 2011-04-14 14:39:53 EDT
This is an async issue.  It's possible that the datasource fetch is calling its completion callback before we're done actually loading the tree.

I think this is due to our making async calls while we process the fetch results. Still investigating...
Comment 2 Jay Shaughnessy 2011-04-15 09:07:39 EDT
The code looked good but didn't work in all cases. I suspect maybe a smartgwt
problem.  A added what should be unnecessary code to get it to work. Seems
ok but don't know if it will last forever. Maybe in a future version of
smartgwt we can remove it.

Test Notes: General tree nav should be executed but additionally:

1) Nav to RHQ Agent resource
   Resource Tree should be expanded correctly and agent resource selected.

2) Nav to Alerts->History subtab
   (the specific subtab does not really matter but I was using this one)
   No change to the tree

3) Nav to Reports
   Tree is gone, reports section stack is there

4) Click Browser back to return to alerts history subtab
   Resource Tree should be expanded like in step 1.  If the problem shows up
   only the root platform node will be displayed
Comment 3 Sunil Kondkar 2011-04-25 05:08:20 EDT
Verified on build#1175(Version: 4.0.0-SNAPSHOT Build Number: a90faf9)

Verified the general tree navigation along with the below:
Navigation to the RHQ Agent resource, Alerts->History sub tab, Reports section and then 'Back' browser button to return to alerts history sub tab.
The resource tree is expanded.
Also verified in some other areas like the 'Resource' links in Reports section.

Marking as verified.
Comment 4 Corey Welton 2011-05-23 21:10:03 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.