Bug 696741 - ctime, mtime, modifiedBy, itime, and connected fields are missing from resource summary header
ctime, mtime, modifiedBy, itime, and connected fields are missing from resour...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-14 14:38 EDT by Ian Springer
Modified: 2013-08-05 20:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-04-14 14:38:58 EDT
These fields should be included. It would also be nice to include them as columns, hidden by default, in the resource list/search view, so that users could unhide them if they wanted to sort by them.

We should also consider displaying the resourceKey field, though possibly only when the the debug system setting is enabled.
Comment 1 Ian Springer 2011-04-15 12:11:54 EDT
Done - [master 27a33d6].

NOTES:
- 'connected' field is not included, since it appears to not currently be used for anything (value is always false)
- all the other new fields are hidden by default on the resource list view
- resource key is always displayed in summary header (debug mode system setting does not need to be enabled); I think it's useful enough to always display
Comment 2 Sunil Kondkar 2011-05-04 06:47:30 EDT
Verified on rhq4 release build (Version: 4.0.0 Build Number: db0c817)

The fields 'Discovery Time', 'import Time', 'Last Modified Time', 'Last Modifier' and 'Key' are hidden  by default in resource list/search view. User can unhide and sort with these columns. Verified sorting by these fields. Connected field is not displayed.

Marking as verified.
Comment 3 Corey Welton 2011-05-23 21:17:51 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:17:51 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:17:55 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:17:57 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.