Bug 696753 - Ignoring resources fails
Ignoring resources fails
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta2
All All
urgent Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: jon3 rhq401
  Show dependency treegraph
 
Reported: 2011-04-14 15:09 EDT by Heiko W. Rupp
Modified: 2011-05-23 21:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of what to ignore (20.31 KB, image/png)
2011-04-14 15:09 EDT, Heiko W. Rupp
no flags Details

  None (edit)
Description Heiko W. Rupp 2011-04-14 15:09:02 EDT
Created attachment 492203 [details]
Screenshot of what to ignore

I've imported a platform sans a few resoures with success.
Then I've clicked on the platform, then on yes at the "include servers" prompt and clicked on ignore.

Ignoring failed with the red bar.

Actually it seems that the platform children were successfully ignored, but as the platform was selected too, the total operation failed.
Comment 1 Jay Shaughnessy 2011-04-20 17:12:11 EDT
I can not get this to reproduce.  The only time I've seen an error it was a timeout because the agent was down, which is expected. The resources still get ignored server-side so things actually work.

I've tested with FireFox and Chrome.

I need more specific repro steps, assuming this is still a problem. Asking for more info...
Comment 2 Heiko W. Rupp 2011-04-21 06:11:12 EDT
I can't reproduce it at the moment, but suspect that it may have to do with the 
total amount of resources to ignore and the speed of the computer / database, 
so that the operation just runs into a timeout.
Comment 3 Jay Shaughnessy 2011-04-21 08:44:04 EDT
The timeout for this, and by default any server-side RPC call is set to 10 seconds.  It should be long enough to perform even a large inventory status change but we'll need to keep an eye on this one.
Comment 4 Charles Crouch 2011-04-25 11:50:07 EDT
Unassigning as work has stopped
Comment 5 Jay Shaughnessy 2011-04-25 11:54:44 EDT
Submitting to QA for final validation.
Comment 6 John Mazzitelli 2011-05-02 11:59:25 EDT
the same issue happens on "import" - see bug #701314 for more
Comment 7 John Mazzitelli 2011-05-03 14:47:35 EDT
master commit 8534967

this commit bumps up the timeout to 1 minute. In addition, if that still isn't enough, we'll log a warning message that tells the user about the timeout but that the server is still processing the request.

hard to test this - I guess just ignore lots of resources in the discovery queue and see that you don't get a timeout (which used to be 10s - so if your request is over 10s and completes successfully, OR you get a yellow warning message, this issue is fixed)
Comment 8 Charles Crouch 2011-05-09 16:16:18 EDT
Added for triage for RHQ4.0.1
Comment 9 John Mazzitelli 2011-05-10 12:29:11 EDT
cherry picked over to release-4.0.0 branch as commit: 9b953bd567a507e890c7ee2688c1e9c803cee88e
Comment 10 Mike Foley 2011-05-12 11:30:41 EDT
verified.  tested inventory, univnentory, ignore, import.  all looks good.  rhq 4.0.1
Comment 11 Corey Welton 2011-05-23 21:17:54 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 12 Corey Welton 2011-05-23 21:17:56 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 13 Corey Welton 2011-05-23 21:17:57 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 14 Corey Welton 2011-05-23 21:17:58 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.