Bug 696814 - LVMError: lvdeactivate failed for lv_swap:
Summary: LVMError: lvdeactivate failed for lv_swap:
Keywords:
Status: CLOSED DUPLICATE of bug 629253
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:caff1f1d7cb5fa06e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-14 22:10 UTC by Steve Tyler
Modified: 2011-04-15 11:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-15 02:13:47 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (335.77 KB, text/plain)
2011-04-14 22:11 UTC, Steve Tyler
no flags Details

Description Steve Tyler 2011-04-14 22:10:56 UTC
The following was filed automatically by anaconda:
anaconda 15.27 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/lvm.py", line 400, in lvdeactivate
    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 2466, in _teardown
    lvm.lvdeactivate(self.vg.name, self._name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 716, in teardown
    self._teardown(recursive=recursive)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 486, in execute
    self.device.teardown()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 313, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 116, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1346, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1258, in nextClicked
    self.setScreen ()
LVMError: lvdeactivate failed for lv_swap:

Comment 1 Steve Tyler 2011-04-14 22:11:01 UTC
Created attachment 492241 [details]
Attached traceback automatically from anaconda.

Comment 2 Steve Tyler 2011-04-14 22:24:39 UTC
This was in a VM:
$ qemu-kvm -m 592 -cdrom Fedora-15-Beta-x86_64-netinst.iso -hda ../f15-test1.img -boot menu=on

I had previously successfully completed a 32-bit install with the default, full-disk partitioning onto the same disk image:
$ qemu-kvm -m 560 -cdrom Fedora-15-Beta-i386-netinst.iso -hda ../f15-test1.img -boot menu=on

This seems to be reproducible. Restarting the VM and restarting the 64-bit install onto the same image fails with a python traceback while writing the partitions and logical volumes.

Comment 3 Chris Lumens 2011-04-15 02:13:47 UTC
You need more memory in the VM (for now):

22:08:26,049 ERR kernel:[   71.708412] Out of memory: Kill process 342 (anaconda) score 73 or sacrifice child
22:08:26,049 ERR kernel:[   71.708416] Killed process 935 (lvm) total-vm:79296kB, anon-rss:21704kB, file-rss:2040kB

Comment 4 Steve Tyler 2011-04-15 11:18:30 UTC
(In reply to comment #3)
> You need more memory in the VM (for now):
> 
> 22:08:26,049 ERR kernel:[   71.708412] Out of memory: Kill process 342
> (anaconda) score 73 or sacrifice child
> 22:08:26,049 ERR kernel:[   71.708416] Killed process 935 (lvm)
> total-vm:79296kB, anon-rss:21704kB, file-rss:2040kB

I was testing low-memory behavior, so this is not a surprise.
Cross-reference:
Bug 696805 - installer does not report insufficient memory or swap

This bug is more akin to the still open
installer-does-not-handle-oom-gracefully bug:
Bug 629253 - anaconda: system freezes on installing selinux

*** This bug has been marked as a duplicate of bug 629253 ***


Note You need to log in before you can comment on or make changes to this bug.