Bug 69682 - Traceback attempting to remove nfs share
Traceback attempting to remove nfs share
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-nfs (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-24 09:54 EDT by Jay Turner
Modified: 2015-01-07 18:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-11 23:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2002-07-24 09:54:11 EDT
Description of Problem:
With redhat-config-nfs-0.9.4-3, there are a couple of odd things going on. 
First, if you attempt to remove shares, they don't actually get removed.  The
/etc/exports file doesn't get updated, the share continues to be exported.

If you don't have nfs running, and remove the lone share and attempt to quit,
you will get prompted that the nfs service isn't running and would you like to
start it.  Clicking 'yes' results in the following traceback:

Traceback (most recent call last):
  File "/usr/share/redhat-config-nfs/mainWindow.py", line 256, in
+on_apply_button_clicked
    self.exports.writeFile(self.processData())
  File "/usr/share/redhat-config-nfs/mainWindow.py", line 160, in processData
    nfsDataObject = self.exportsStore.get_value(iter, 3)
TypeError: iter must be a GtkTreeIter

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Brent Fox 2002-07-24 23:10:08 EDT
Can you attach the /etc/exports file?

Did you start from scratch or was there an existing /etc/exports file?
Comment 2 Jay Turner 2002-07-25 07:18:32 EDT
At the start, I have this in /etc/exports:

/spare                   *.redhat.com(ro,sync)

and nfs is not running:
[root@kokopelli root]# service nfs status
rpc.mountd is stopped
nfsd is stopped
rpc.rquotad is stopped

I launch redhat-config-nfs and get the display showing the above export.  I
click on it, then click 'Delete'.  The export is deleted from the display and I
click "Apply" and get the message that the nfs service isn't running, would I
like to start it.  Clicking either 'yes' or 'no' results in the traceback and
/etc/exports is left unmodified.

TRY #2:
I start the nfs service and repeat the steps above.  This time when I click
apply I don't get prompted to start the service (as it's already running) but I
do still get the traceback.
Comment 3 Brent Fox 2002-08-07 01:16:43 EDT
Can you reproduce this for me?  I am unable to reproduce it on my machines.
Comment 4 Brent Fox 2002-08-11 23:03:41 EDT
Oh wait, I can reproduce it.  The bug is caused when the list store is empty,
and the program tries to retrieve data from an empty list.  I will fix now.
Comment 5 Brent Fox 2002-08-11 23:13:36 EDT
Should be fixed in 0.9.9-2.  I will rebuild it later tonight.  There's a few
other bugfixes I'd like to get in to 0.9.9-2.
Comment 6 Jay Turner 2002-08-12 12:11:34 EDT
Fix confirmed with redhat-config-nfs-0.9.9-2.

Note You need to log in before you can comment on or make changes to this bug.