Bug 696835 - virt-manager refuses to run a VM with attached host USB device: libvirtError: internal error USB host device is missing bus/device information
virt-manager refuses to run a VM with attached host USB device: libvirtError:...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.6
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 20:26 EDT by Roman
Modified: 2012-07-03 05:29 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 574136
Environment:
Last Closed: 2012-01-30 17:11:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman 2011-04-14 20:26:30 EDT
+++ This bug was initially created as a clone of Bug #574136 +++

I had a bug where I couldn't add a USB host device to a virt-manager machine (but if I did it manually in the XML config, it worked). Now that's been fixed, but replaced with a worse bug - I can't start up a VM with an attached host USB device, whether the device was added by manually editing the config or using virt-manager.

When I try to start the machine, I get this error:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 589, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1208, in startup
    self._backend.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 300, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error USB host device is missing bus/device information

if I remove the USB device from the machine config, it starts up fine.

The device is a Sony Reader, USB ID 054c:031e , lsusb -v output will be attached. Nothing particularly exciting shows up in /var/log/messages , just:

Mar 16 10:47:46 adam libvirtd: 10:47:46.639: error : qemuBuildUSBHostdevDevStr:2733 : internal error USB host device is missing bus/device information

Restarting libvirtd throws these messages:

Mar 16 10:51:28 adam libvirtd: 10:51:28.271: warning : qemudDispatchSignalEvent:385 : Shutting down on signal 15
Mar 16 10:51:30 adam libvirtd: 10:51:30.114: error : udevStrToLong_ui:78 : Failed to convert 'ff' to unsigned int
Mar 16 10:51:30 adam libvirtd: 10:51:30.131: error : udevStrToLong_ui:78 : Failed to convert '0e' to unsigned int
Mar 16 10:51:30 adam libvirtd: 10:51:30.132: error : udevStrToLong_ui:78 : Failed to convert '0e' to unsigned int
Mar 16 10:51:30 adam libvirtd: 10:51:30.213: warning : qemudStartup:1099 : Unable to create cgroup for driver: No such device or address
Mar 16 10:51:30 adam kernel: lo: Disabled Privacy Extensions
Mar 16 10:51:30 adam libvirtd: 10:51:30.467: warning : lxcStartup:1755 : Unable to create cgroup for driver: No such device or address

--- Additional comment from awilliam@redhat.com on 2010-03-16 13:53:05 EDT ---

Created attachment 400517 [details]
lsusb -v output for the device in question

--- Additional comment from crobinso@redhat.com on 2010-03-16 14:17:54 EDT ---

This is already fixed upstream, will be backported to F13 shortly

*** This bug has been marked as a duplicate of bug 537227 ***

--- Additional comment from awilliam@redhat.com on 2010-03-16 14:36:49 EDT ---

Unless you're using 537227 to cover multiple problems, it's not the same bug. That one is the problem which can be worked around by setting SELinux to Permissive, which I was running into before (notice that I've already commented on that bug). This is a different error, and it doesn't work even if you set SELinux to Permissive.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from crobinso@redhat.com on 2010-03-16 15:37:24 EDT ---

Doh, my bad, reopening.

This is fixed by the following commit:

http://libvirt.org/git/?p=libvirt.git;a=commit;h=6d5c8a8f51db8ce97ab35ab6022dd5c94ab016b4

With this and the fix for 537227, USB devices attached via virt-manager should work with svirt.

--- Additional comment from crobinso@redhat.com on 2010-03-17 14:13:51 EDT ---

*** Bug 574501 has been marked as a duplicate of this bug. ***

--- Additional comment from updates@fedoraproject.org on 2010-03-22 12:34:21 EDT ---

libvirt-0.7.7-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libvirt-0.7.7-2.fc13

--- Additional comment from updates@fedoraproject.org on 2010-03-23 19:22:25 EDT ---

libvirt-0.7.7-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libvirt-0.7.7-2.fc13

--- Additional comment from updates@fedoraproject.org on 2010-03-23 20:42:28 EDT ---

libvirt-0.7.7-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from bopohob@gmail.com on 2011-04-13 17:15:21 EDT ---

Hi,

I just upgraded my Virtual Manager as wella as my CentOS and I cannot run my Windows XP 64 virtual machine because of a similar error:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 501, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 575, in startup
    self.vm.create()
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error USB host device is missing bus/device information

I have virt-manager 0.6.1, and CentOS release 5.6 (Final). My SELinux is set to disabled. Please help, I need to have access to the files in the virtual machine!  My win 7 32bit virtual machine is unaffected. Thanks.

~Roman

Note You need to log in before you can comment on or make changes to this bug.