Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 696864 - [abrt] ibus-chewing-1.3.9.2-2.fc15: Process /usr/libexec/ibus-engine-chewing was killed by signal 6 (SIGABRT)
[abrt] ibus-chewing-1.3.9.2-2.fc15: Process /usr/libexec/ibus-engine-chewing ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-chewing (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ding-Yi Chen
Fedora Extras Quality Assurance
abrt_hash:fdf5fd60f2b5a6935685e440f1a...
:
: 664011 (view as bug list)
Depends On:
Blocks: F15Blocker/F15FinalBlocker
  Show dependency treegraph
 
Reported: 2011-04-15 00:05 EDT by Cheng-Chia Tseng
Modified: 2011-05-31 01:40 EDT (History)
10 users (show)

See Also:
Fixed In Version: ibus-chewing-1.3.9.2-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-03 00:44:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (14.93 KB, text/plain)
2011-04-15 00:05 EDT, Cheng-Chia Tseng
no flags Details
File: smaps (126.97 KB, text/plain)
2011-04-15 00:06 EDT, Cheng-Chia Tseng
no flags Details
File: maps (28.86 KB, text/plain)
2011-04-15 00:06 EDT, Cheng-Chia Tseng
no flags Details
File: dsos (20.12 KB, text/plain)
2011-04-15 00:06 EDT, Cheng-Chia Tseng
no flags Details
File: backtrace (21.32 KB, text/plain)
2011-04-15 00:06 EDT, Cheng-Chia Tseng
no flags Details

  None (edit)
Description Cheng-Chia Tseng 2011-04-15 00:05:53 EDT
abrt version: 2.0.0
executable: /usr/libexec/ibus-engine-chewing
cmdline: /usr/libexec/ibus-engine-chewing --ibus
component: ibus-chewing
package: ibus-chewing-1.3.9.2-2.fc15
crash_function: ibus_lookup_table_append_label
kernel: 2.6.38.2-9.fc15.x86_64
reason: Process /usr/libexec/ibus-engine-chewing was killed by signal 6 (SIGABRT)
uid: 500
architecture: x86_64
username: realplus
os_release: Fedora release 15 (Lovelock)
time: 1302839064
rating: 4

Text file: event_log, 15285 bytes
Text file: smaps, 130021 bytes
Binary file: coredump, 11939840 bytes
Text file: maps, 29557 bytes
Text file: dsos, 20606 bytes
Text file: backtrace, 21835 bytes

comment
-----
1. Use Chinese (Taiwan) in "Region and Language" of System Settings.
2. Relogin.
3. Open gedit.
4. Press "Ctl + Space" to activate ibus-chewing input method.
5. ibus-chewing crashed.
Comment 1 Cheng-Chia Tseng 2011-04-15 00:05:57 EDT
Created attachment 492267 [details]
File: event_log
Comment 2 Cheng-Chia Tseng 2011-04-15 00:06:01 EDT
Created attachment 492268 [details]
File: smaps
Comment 3 Cheng-Chia Tseng 2011-04-15 00:06:04 EDT
Created attachment 492269 [details]
File: maps
Comment 4 Cheng-Chia Tseng 2011-04-15 00:06:06 EDT
Created attachment 492270 [details]
File: dsos
Comment 5 Cheng-Chia Tseng 2011-04-15 00:06:09 EDT
Created attachment 492271 [details]
File: backtrace
Comment 6 Hao Tang 2011-04-20 15:51:49 EDT
I can confirm this bug.
Comment 7 Cheng-Chia Tseng 2011-04-25 11:31:33 EDT
Fedora 15 is going out soon.

If this bug cannot be solved in the release, it will be so hard for the Chinese (Traditional) users to have positive views for Fedora. It also hinders ambassaders from promoting Fedora in whole Chinese (Traditional) using regions.

I strongly hope this bug can be fixed in Fedora 15.
Comment 8 Daiki Ueno 2011-04-26 02:38:05 EDT
I created a test package for this:
http://ueno.fedorapeople.org/ibus-chewing/
since it sounds important for Chinese users and Ding seems busy.

The patch applied has been already in the upstream.
Comment 9 Daiki Ueno 2011-04-26 02:42:15 EDT
*** Bug 664011 has been marked as a duplicate of this bug. ***
Comment 10 Cheng-Chia Tseng 2011-04-26 05:30:32 EDT
The test package works.

Thank you, Daiki Ueno! :)
Comment 11 Daiki Ueno 2011-04-27 02:01:51 EDT
Marking this as F15Blocker, since this bug is related to the unmet Final Release Requirement: All elements of the default panel (or equivalent) configuration must function correctly in common use.
Comment 12 Fedora Update System 2011-04-27 02:03:16 EDT
ibus-chewing-1.3.9.2-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-chewing-1.3.9.2-3.fc15
Comment 13 Fedora Update System 2011-04-28 15:00:49 EDT
Package ibus-chewing-1.3.9.2-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-chewing-1.3.9.2-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-chewing-1.3.9.2-3.fc15
then log in and leave karma (feedback).
Comment 14 Adam Williamson 2011-04-29 13:53:46 EDT
Discussed at 2011-04-29 blocker review meeting. Accepted as a blocker: this does affect the criterion cited in comment #11 in a traditional Chinese install, and the practical impact is also severe.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Jens Petersen 2011-05-02 03:47:52 EDT
ibus-chewing-1.3.9.2-3.fc15 fixes the problem for me.

I have requested the package be moved to stable now that it has been
some days in testing already.
Comment 16 James Laska 2011-05-02 08:01:16 EDT
(In reply to comment #15)
> ibus-chewing-1.3.9.2-3.fc15 fixes the problem for me.

Thanks for the test feedback
Comment 17 James Laska 2011-05-02 08:02:14 EDT
(In reply to comment #15)

> I have requested the package be moved to stable now that it has been
> some days in testing already.

Are there any additional lists we can reach out to for users who may be able to provide test feedback?
Comment 18 Fedora Update System 2011-05-03 00:44:38 EDT
ibus-chewing-1.3.9.2-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Ding-Yi Chen 2011-05-31 01:40:46 EDT
Thanks Daiki Ueno for handling this issue for me.

Note You need to log in before you can comment on or make changes to this bug.