Bug 69693 - Terminal crashes on resizing window
Terminal crashes on resizing window
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-24 11:13 EDT by Joost van der Sluis
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-25 15:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joost van der Sluis 2002-07-24 11:13:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
if there's lot of text in a terminal-window and you use the lower-right
corner to resize the window, the terminal crashes.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open much text in a terminal window. (less license, or pico license)
2. click on the lower-right corner of the window and hold the mouse
button
3. move the mouse in a few circles so you constantly resizes the window

Actual Results:  The terminal crashes (and the gnome-bug-buddy comes alive)

Expected Results:  No crash

Additional info:

Bug-buddy's backtrace:

Backtrace was generated from '/usr/bin/gnome-terminal'

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1024 (LWP 2968)]
0x4209ce49 in wait4 () from /lib/i686/libc.so.6
#0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6
#1  0x4211422c in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x408aea43 in waitpid () from /lib/i686/libpthread.so.0
#3  0x405b3735 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0

Thread 1 (Thread 1024 (LWP 2968)):
#0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6
No symbol table info available.
#1  0x4211422c in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x408aea43 in waitpid () from /lib/i686/libpthread.so.0
No symbol table info available.
#3  0x405b3735 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
No symbol table info available.
#0  0x4209ce49 in wait4 () from /lib/i686/libc.so.6
Comment 1 Nalin Dahyabhai 2002-07-25 09:00:43 EDT
I couldn't reproduce this with the Raw Hide version of vte.  Which version of
the vte package do you have installed?  (I suspect it was fixed in 0.4.9 along
with various other cell initialization problems.)
Comment 2 Joost van der Sluis 2002-07-25 09:52:37 EDT
i have vte-0.4.5-2. How can i get the newer version to check this?
Comment 3 Nalin Dahyabhai 2002-07-25 15:53:13 EDT
Raw Hide (regular snapshots of the development tree) can be found at
ftp.redhat.com:/pub/redhat/linux/rawhide/i386/RedHat/RPMS/.

You'll need to update both vte and gnome-terminal at the same time because the
version of the shared library has changed.  If you have any copies of
gnome-terminal running while installing the updates, you'll need to start a new
copy using the "--disable-factory" option or close all gnome-terminals before
starting a new one, otherwise the running gnome-terminal will simply open a new
window.

Given that you're using 0.4.5, I'm almost certain that this will turn out to be
a duplicate of #67930.
Comment 4 Jay Turner 2002-07-29 09:25:53 EDT
Not able to replicate this with vte-0.5.3-2 and gnome-terminal-2.0.0.90-3.

Note You need to log in before you can comment on or make changes to this bug.