Bug 696995 - cannot alert on events
cannot alert on events
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta1
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-15 10:29 EDT by John Mazzitelli
Modified: 2011-05-23 21:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-04-15 10:29:36 EDT
For some reason, the alert condition editor no longer provides the option to alert on events.
Comment 1 Charles Crouch 2011-04-18 19:54:29 EDT
Possibly related issue from 4/8. I presume this thread is referring to the latest RHQ4 Beta, but I didnt' confirm.

(4:47:38 PM) Theaxiom: I am trying to configure alerting in RHQ, everything was fine then I went to configure the next platform and now when I click on conditions for alerting I am unable to select Events for my conditions. What the heck is going on? I restarted the server, I have restarted the agents and the problem persists.
(4:47:42 PM) Theaxiom: It is extremely frustrating.
(5:40:17 PM) Theaxiom: any ideas?
(5:40:24 PM) Theaxiom: is it because I have a / in my alert name?
(5:43:16 PM) Theaxiom: oh man how I don't have time for this :(
(5:43:38 PM) Theaxiom: what would cause me not to be able to select events in the alerts conditions dropdown?
(5:43:46 PM) Theaxiom: Event is not even listed in that box, and it is random
(5:54:38 PM) Theaxiom: :'(
(6:01:45 PM) Theaxiom: ok this REALLY sucks
(6:01:52 PM) Theaxiom: I don't know what else to do, I tried even restarting the agent
(6:04:36 PM) Theaxiom: http://imgbin.org/index.php?page=image&id=3762
(6:05:46 PM) ccrouch: Theaxiom: and you this was working on some other resource?
(6:06:23 PM) Theaxiom: ccrouch, yes it was previously working on THIS resource too, but now it isn't - the alert that I had created before, I deleted it to see if I could re-create it, and I can't add the conditions again. :(
(6:07:04 PM) ccrouch: hmm
(6:07:41 PM) ccrouch: and the events collection are still enabled?
(6:08:01 PM) Theaxiom: ccrouch, yep, I tried disabling and re-enabling to see if that would fix it, but didn't work
(6:08:31 PM) ccrouch: have you tried a different resource?
(6:08:45 PM) Theaxiom: ccrouch, yeah, and it works on some now, and not on others, and it is random
(6:10:26 PM) Theaxiom: ccrouch, now it's not working on another resource it was working on not too long ago
(6:10:31 PM) Theaxiom: ccrouch, it's crazy
(6:12:44 PM) ccrouch: hmm
(6:12:44 PM) ccrouch: well that doesn't sound right
(6:12:44 PM) ccrouch: can you raise a bug (https://bugzilla.redhat.com/enter_bug.cgi?product=RHQ%20Project)
(6:12:44 PM) ccrouch: and try to capture anything that might be different about the resources
(6:12:56 PM) ccrouch: Theaxiom: what resource types are you trying this on?
(6:13:22 PM) Theaxiom: ccrouch, windows platforms
(6:14:31 PM) ccrouch: try a different resource type that supports events, e.g. jbas
(6:15:04 PM) Theaxiom: ccrouch, ok
(6:15:21 PM) ccrouch: and let us know in the bug if that works any differently
(6:17:34 PM) Theaxiom: ccrouch, no go
(6:18:33 PM) Theaxiom: ccrouch, seems to me some module or something got corrupted
(6:32:48 PM) ccrouch: something is definitely bust
(6:33:07 PM) ccrouch: I can add event based alerts on linux platforms, with no log configured
(6:33:21 PM) Theaxiom: ccrouch, yeah it was working before, but it isn't now
(6:33:24 PM) ccrouch: but i can't add them on jbas servers, even after i configured a logging source
(6:33:42 PM) ccrouch: raise a bug and we'll take a look
(6:34:49 PM) Theaxiom: ccrouch, http://pastebin.com/PMp0K5Q7
(6:35:17 PM) Theaxiom: ccrouch, that's the server log when I try to add those conditions
(6:37:42 PM) Theaxiom: I will be back later
(6:37:48 PM) ccrouch: that may help track it down
(6:37:54 PM) ccrouch: please add it to the bug
Comment 2 John Mazzitelli 2011-04-19 14:27:05 EDT
I think I found a workaround for this problem.

Expand the left-hand tree and select the resource that you want to create the event alert for. Once you selected the tree node and you are viewing that resource, hit F5 (force a full reload). Now go immediately to the alert definition subtab and create the new definition. You should be able to see the "event" condition type to choose from.

The problem seems to stem from the loading/caching of the resource types and their metadata. I don't know why having the resource selected forces the event metadata to be loaded, but traversing to the resource from another resource does not. But at least it seems we have a workaround.
Comment 3 John Mazzitelli 2011-04-19 14:52:31 EDT
commit 855afab

fixed problem in ResourceTypeRepository - events metadata is now properly loaded in the type object

to test:

1) have a platform and a rhq agent resource in inventory
2) go to the platform resource and once the page loads, hit F5 to ensure you are fully refreshed and type metadata cache is cleared
3) create an alert definition for the platform that has a event condition
4) now click on the RHQ Agent resource node in the left hand tree
5) similar to step 3 - create an alert definition for the agent that has an event condition
Comment 4 Sunil Kondkar 2011-04-26 05:24:32 EDT
Verified on build#1175 (Version: 4.0.0-SNAPSHOT Build Number: a90faf9)

Navigated to the platform resource, did F5, created an alert selecting 'Event Detection' value from 'condition type' dropdown and saved the alert.

Clicked on the RHQ Agent resource node in the left hand tree and successfully created an alert for RHQ Agent selecting 'Event Detection' value from 'condition type' dropdown.

Marking as verified.
Comment 5 Corey Welton 2011-05-23 21:13:16 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:13:16 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:13:16 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.