Bug 697006 - Preparing /etc/exports.d when nfs-utils packge is installed
Preparing /etc/exports.d when nfs-utils packge is installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-15 11:04 EDT by Masatake YAMATO
Modified: 2011-09-28 21:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.4-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-27 06:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch which may fix this issue (590 bytes, patch)
2011-04-15 11:04 EDT, Masatake YAMATO
no flags Details | Diff

  None (edit)
Description Masatake YAMATO 2011-04-15 11:04:19 EDT
Created attachment 492410 [details]
A patch which may fix this issue

Description of problem:

The latest nfs-utils introduced /etc/exports.d; the files under the directory are loaded as if they are part of /etc/exports.

Added/removing a new export point to the system becomes easier; just put or remove a file under the directory.

However, /etc/exports.d is not provided by the package. So fedora users cannot receive the benefit of the new feature.


Version-Release number of selected component (if applicable):

1.2.3-12f16.

How reproducible:

ls -l /etc/exports.d

Steps to Reproduce:
1.
2.
3.
  
Actual results:

No such file or directory.

Expected results:

The directoy is listed.

Additional info:
Comment 1 Michael Schwendt 2011-07-24 07:59:57 EDT
Indeed, also because exportfs complains about the missing dir, too:

# exportfs -a
exportfs: scandir /etc/exports.d: No such file or directory

# rpm -q nfs-utils
nfs-utils-1.2.4-0.fc15.x86_64
Comment 2 Fedora Update System 2011-09-14 13:59:51 EDT
nfs-utils-1.2.4-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nfs-utils-1.2.4-3.fc15
Comment 3 Fedora Update System 2011-09-15 22:01:26 EDT
Package nfs-utils-1.2.4-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nfs-utils-1.2.4-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/nfs-utils-1.2.4-3.fc15
then log in and leave karma (feedback).
Comment 4 Hongqing Yang 2011-09-27 06:31:37 EDT
verified with nfs-utils-1.2.4-2.fc15.x86_64
Comment 5 Masatake YAMATO 2011-09-27 08:13:38 EDT
Works fine. Thank.
Comment 6 Fedora Update System 2011-09-28 21:35:42 EDT
nfs-utils-1.2.4-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.