Bug 697039 - traits subtab blows up for groups
traits subtab blows up for groups
Status: CLOSED DUPLICATE of bug 695753
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-15 12:45 EDT by John Mazzitelli
Modified: 2011-04-18 20:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-18 20:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server-exception.txt (13.55 KB, text/plain)
2011-04-15 12:45 EDT, John Mazzitelli
no flags Details

  None (edit)
Description John Mazzitelli 2011-04-15 12:45:58 EDT
Created attachment 492433 [details]
server-exception.txt

I had a compat group containing 3 agents. Went to traits subtab and got an error during the load:
	
Message : Failed to fetch traits for criteria [org.rhq.core.domain.criteria.MeasurementDataTraitCriteria@1813].

Severity : Error

Time : Friday, April 15, 2011 12:40:49 PM Etc/GMT+4

Detail :

java.lang.RuntimeException:[1302885648489] javax.ejb.EJBException:javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not execute query -> javax.persistence.PersistenceException:org.hibernate.exception.SQLGrammarException: could not execute query -> org.hibernate.exception.SQLGrammarException:could not execute query -> java.sql.SQLException:ORA-00907: missing right parenthesis [SQLException=ORA-00907: missing right parenthesis ]
--- STACK TRACE FOLLOWS ---
[1302885648489] javax.ejb.EJBException:javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not execute query -> javax.persistence.PersistenceException:org.hibernate.exception.SQLGrammarException: could not execute query -> org.hibernate.exception.SQLGrammarException:could not execute query -> java.sql.SQLException:ORA-00907: missing right parenthesis [SQLException=ORA-00907: missing right parenthesis ]
    at Unknown.java_lang_RuntimeException_$RuntimeException__Ljava_lang_RuntimeException_2Ljava_lang_RuntimeException_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_core_java_lang_RuntimeException_1FieldSerializer_instantiate__Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_RuntimeException_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_$readObject__Lcom_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)

The associated server side exception will be attached
Comment 1 John Mazzitelli 2011-04-15 12:47:07 EDT
note that I was using oracle 10 at the time
Comment 2 Charles Crouch 2011-04-18 20:14:47 EDT

*** This bug has been marked as a duplicate of bug 695753 ***

Note You need to log in before you can comment on or make changes to this bug.