Bug 697065 - not being asked for confirmation before deleting group definition
not being asked for confirmation before deleting group definition
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta1
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-15 13:59 EDT by John Mazzitelli
Modified: 2013-08-05 20:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:14:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-04-15 13:59:47 EDT
1) Create a group definition (aka dynagroup definition).
2) in the group def list, select the new group def and click delete button

notice the def is deleted immediately without asking me "Are You Sure?".
I think we need to ask for confirmation because this delete action has the potential of deleting large amounts of data (a group def could have calcuated many dynagroups). Just to make sure the user really wants to do this, we should ask for confirmation.

blocking rhq4 release so we at least triage this. I think its simple enough that we should fix it now.
Comment 1 Ian Springer 2011-04-15 17:07:56 EDT
Fixed - [master 3ca6d58].
Comment 2 Sunil Kondkar 2011-05-05 07:23:32 EDT
Verified on rhq4 release build. (Version: 4.0.0 Build Number: db0c817)

Created a dynagroup definition, navigated to the group definition list. Selected the definition and clicked 'Delete' button. It displayed the confirmation message and after clicking yes on the confirmation message, the dynagroup definition is deleted successfully.
Comment 3 Corey Welton 2011-05-23 21:14:01 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:14:01 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:14:01 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.