Bug 6971 - Xconfig in install choses badly for NeoMagic
Xconfig in install choses badly for NeoMagic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-12 20:39 EST by Joe Harrington
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-18 17:33:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 1999-11-12 20:39:48 EST
I have a Toshiba Tecra 8000, 13" screen, with NeoMagic.  When I asked to
configure X and selected 1024x768, it was unable to find any modes at all
and the server failed to start.  I reinstalled without configuring modes
and got the 640x480 mode that the install uses.  The XF86Config file
distributed with the XFCom server worked fine under RH 5.2 at 1024x768...

--jh--
Comment 1 Joe Harrington 1999-11-15 15:20:59 EST
I just brought over the old file and it works under 6.1.  It defines just three
modes, all of which are defined in the file I was left with after the install.
However, for some reason they work only when other modes are not also defined.
Here is the working Monitors section:

Section "Monitor"
    Identifier  "Generic Multisync"
    VendorName  "Unknown"
    ModelName   "Unknown"
    HorizSync   30-64
    VertRefresh 50-100
# 640x480 @ 60 Hz, 31.5 kHz hsync
    Modeline "640x480"     25.175 640  664  760  800
                                  480  491  493  525
# 800x600 @ 60 Hz, 37.8 kHz hsync
    Modeline "800x600"     40     800  840  968 1056
                                  600  601  605  628 +hsync +vsync
# 1024x768 @ 60 Hz, 48.4 kHz hsync
    Modeline "1024x768"    65    1024 1032 1176 1344
                                  768  771  777  806 -hsync -vsync
EndSection

I also eliminated the 1152x864 modes from the Modes lines in the Screen section,
since there aren't that many pixels on the laptop's display.  And obviously, I
changed the Monitor name to "Generic Multisync".  Those were the only changes.
Here's a diff:

# diff -c XF86Config XF86Config.1-6.1inst-640-only
*** XF86Config  Mon Nov 15 09:12:49 1999
--- XF86Config.1-6.1inst-640-only       Fri Nov 12 11:32:59 1999
***************
*** 142,166 ****
                                    480 491 493 525
  EndSection

- # This section works.  The next doesn't, even though all the same
- # modes are listed.  Don't know why.  Use this
- Section "Monitor"
-     Identifier  "Generic Multisync"
-     VendorName  "Unknown"
-     ModelName   "Unknown"
-     HorizSync   30-64
-     VertRefresh 50-100
- # 640x480 @ 60 Hz, 31.5 kHz hsync
-     Modeline "640x480"     25.175 640  664  760  800
-                                 480  491  493  525
- # 800x600 @ 60 Hz, 37.8 kHz hsync
-     Modeline "800x600"     40     800  840  968 1056
-                                 600  601  605  628 +hsync +vsync
- # 1024x768 @ 60 Hz, 48.4 kHz hsync
-     Modeline "1024x768"    65    1024 1032 1176 1344
-                                 768  771  777  806 -hsync -vsync
- EndSection
-
  Section "Monitor"

      Identifier  "TOS20610"
--- 142,147 ----
***************
*** 456,490 ****
  Section "Screen"
      Driver      "svga"
      Device      "NeoMagic (laptop/notebook)"
!     Monitor     "Generic Multisync"
! #    Monitor     "TOS20610"

      Subsection "Display"
          Depth       16
!         Modes       "1024x768" "800x600" "640x480"
! #        Modes       "1152x864" "1024x768" "800x600" "640x480"
          ViewPort    0 0
      EndSubsection

      Subsection "Display"
          Depth       8
!         Modes       "1024x768" "800x600" "640x480"
! #        Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
!         ViewPort    0 0
!     EndSubsection
!
!     Subsection "Display"
!         Depth       24
! # Not sure that this mode works at all, and if so, if it works in 1024x768...
!         Modes       "1024x768" "800x600" "640x480"
! #        Modes       "800x600" "640x480"
          ViewPort    0 0
      EndSubsection

      Subsection "Display"
          Depth       32
          Modes       "800x600" "640x480"
- #        Modes       "800x600" "640x480"
          ViewPort    0 0
      EndSubsection
  EndSection
--- 437,459 ----
  Section "Screen"
      Driver      "svga"
      Device      "NeoMagic (laptop/notebook)"
!     Monitor     "TOS20610"

      Subsection "Display"
          Depth       16
!         Modes       "1152x864" "1024x768" "800x600" "640x480"
          ViewPort    0 0
      EndSubsection

      Subsection "Display"
          Depth       8
!         Modes       "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
          ViewPort    0 0
      EndSubsection

      Subsection "Display"
          Depth       32
          Modes       "800x600" "640x480"
          ViewPort    0 0
      EndSubsection
  EndSection


--jh--
Comment 2 Trond Eivind Glomsrxd 2000-07-11 13:00:30 EDT
Is this still a problem with 6.2?
Comment 3 Trond Eivind Glomsrxd 2000-07-25 13:37:12 EDT
No feedback, so I'll assume it works with 6.2 (which works fine with my own
Neomagic)
Comment 4 Joe Harrington 2000-07-25 16:08:09 EDT
Sorry not to get back.  My laptop is still in 6.1 and has to stay there until
the class I'm teaching with it is done (2 weeks and counting).  If I find the
problem again I'll reopen, otherwise no news is good news.

--jh--

Note You need to log in before you can comment on or make changes to this bug.