Bug 697196 - [SandyBridge] Intel HD Graphics 2000 artifacts
Summary: [SandyBridge] Intel HD Graphics 2000 artifacts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-16 17:53 UTC by Nickolay Bunev
Modified: 2011-07-29 13:41 UTC (History)
4 users (show)

Fixed In Version: xorg-x11-drv-intel-2.15.0-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-10 19:51:58 UTC
Type: ---


Attachments (Terms of Use)
Xorg log (22.79 KB, text/plain)
2011-04-16 17:53 UTC, Nickolay Bunev
no flags Details
dmesg (66.91 KB, text/plain)
2011-04-16 17:54 UTC, Nickolay Bunev
no flags Details
Snapshot - Artifacts on Dark Color Scheme (564.04 KB, image/png)
2011-04-16 17:55 UTC, Nickolay Bunev
no flags Details
Snapshot - Artifacts on Light Color Scheme (578.09 KB, image/png)
2011-04-16 17:56 UTC, Nickolay Bunev
no flags Details

Description Nickolay Bunev 2011-04-16 17:53:59 UTC
Created attachment 492612 [details]
Xorg log

Description of problem:
There are unpleasant artifacts on right mouse click context menus. This makes it impossible to use them, especially if we use lighter color schemes.

Version-Release number of selected component (if applicable):

[root@Pegasus ~]# rpm -qa | grep intel | grep xorg
xorg-x11-drv-intel-2.14.0-5.fc15.x86_64

[root@Pegasus ~]# rpm -qa | grep kernel
kernel-2.6.38.2-9.fc15.x86_64
kernel-devel-2.6.38.2-9.fc15.x86_64

[root@Pegasus ~]# rpm -qa | grep mesa*
mesa-libGLU-devel-7.11-0.6.20110412.0.fc15.x86_64
mesa-libGLU-7.11-0.6.20110412.0.fc15.x86_64
mesa-dri-filesystem-7.11-0.6.20110412.0.fc15.x86_64
mesa-libGL-devel-7.11-0.6.20110412.0.fc15.x86_64
mesa-dri-drivers-7.11-0.6.20110412.0.fc15.x86_64
mesa-dri-llvmcore-7.11-0.6.20110412.0.fc15.x86_64
mesa-libGL-7.11-0.6.20110412.0.fc15.x86_64

[root@Pegasus ~]# rpm -qa | grep kdebase | grep -v kdebase3
kdebase-runtime-4.6.2-1.fc15.x86_64
kdebase-workspace-4.6.2-2.fc15.x86_64
kdebase-4.6.2-1.fc15.x86_64
kdebase-workspace-libs-4.6.2-2.fc15.x86_64
kdebase-devel-4.6.2-1.fc15.x86_64
kdebase-workspace-devel-4.6.2-2.fc15.x86_64
kdebase-libs-4.6.2-1.fc15.x86_64
kdebase-workspace-wallpapers-4.6.2-2.fc15.noarch
kdebase-runtime-libs-4.6.2-1.fc15.x86_64
kdebase-runtime-flags-4.6.2-1.fc15.noarch

How reproducible:
Always

Steps to Reproduce:
1. Right Click Somewhere
  
Actual results:
Nasty Artifacts

Expected results:
No Artifacts

Additional info:
Fedora 15 Beta via yum (15.04) (yum --releasever=15 --disablerepo=updates --enablerepo=updates-testing,rpmfusion-free-rawhide,rpmfusion-nonfree-rawhide update

[root@Pegasus ~]# lspci -v
00:02.0 VGA compatible controller: Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Intel Corporation Device 2008
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at fe000000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915

Comment 1 Nickolay Bunev 2011-04-16 17:54:47 UTC
Created attachment 492613 [details]
dmesg

Comment 2 Nickolay Bunev 2011-04-16 17:55:36 UTC
Created attachment 492614 [details]
Snapshot - Artifacts on Dark Color Scheme

Comment 3 Nickolay Bunev 2011-04-16 17:56:02 UTC
Created attachment 492615 [details]
Snapshot - Artifacts on Light Color Scheme

Comment 4 Nickolay Bunev 2011-04-17 16:01:26 UTC
Two more things. Аrtifacts occur in the menus of many applications not only in those with right click.
I tried the nightly builds from 20110412.22. There is artifacts on KDE Live, but I can't reproduce the bug with Gnome.

Comment 5 Fedora Update System 2011-05-09 19:11:28 UTC
xorg-x11-drv-intel-2.15.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.15.0-3.fc15

Comment 6 Fedora Update System 2011-05-09 22:38:21 UTC
Package xorg-x11-drv-intel-2.15.0-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-intel-2.15.0-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.15.0-3.fc15
then log in and leave karma (feedback).

Comment 7 Nickolay Bunev 2011-05-10 17:54:55 UTC
The update fix the problem as expected. You can close this bug.

Comment 8 Laurent Aguerreche 2011-05-14 18:41:22 UTC
This new package version fixes probably the problem of KDE users [I don't use KDE applications] but introduces artifacts for GNOME shell users [at least me]. The bottom of every GTK window flickers with black squares when being moved. I didn't have this problem with xorg-x11-drv-intel-2.14.0-6.fc15.x86_64.rpm.

Comment 9 Fedora Update System 2011-05-19 04:54:20 UTC
xorg-x11-drv-intel-2.15.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Laurent Aguerreche 2011-05-19 14:35:18 UTC
As I said, the problem is now very strong on GNOME shell with GTK applications when moving them...

Comment 11 David Mansfield 2011-07-29 13:41:59 UTC
laurent is absolutely correct by the way, the 2.15 version is practically unusable vs 2.14 for me, (intel hd 3000) because of the problem described accurately in comment#8


Note You need to log in before you can comment on or make changes to this bug.