Bug 697243 - [abrt] linkchecker-gui-6.5-1.fc14: editor.py:20:<module>:ImportError: cannot import name Qsci
Summary: [abrt] linkchecker-gui-6.5-1.fc14: editor.py:20:<module>:ImportError: cannot ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linkchecker
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: W. Michael Petullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3143f344
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-17 07:11 UTC by Pavel Alexeev
Modified: 2011-05-29 23:20 UTC (History)
4 users (show)

Fixed In Version: linkchecker-6.5-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 04:59:37 UTC


Attachments (Terms of Use)
File: backtrace (7.16 KB, text/plain)
2011-04-17 07:11 UTC, Pavel Alexeev
no flags Details

Description Pavel Alexeev 2011-04-17 07:11:25 UTC
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 7332 bytes
comment: Package miss dependency qscintilla-python, after that installation application starts.
component: linkchecker
executable: /usr/bin/linkchecker-gui
kernel: 2.6.37-0.rc6.git0.1.fc15.i686.PAE
package: linkchecker-gui-6.5-1.fc14
reason: editor.py:20:<module>:ImportError: cannot import name Qsci
release: Fedora release 14 (Laughlin)
How to reproduce: just start linkchecker-gui
time: 1303024198
uid: 501

Comment 1 Pavel Alexeev 2011-04-17 07:11:27 UTC
Created attachment 492673 [details]
File: backtrace

Comment 2 W. Michael Petullo 2011-05-05 16:13:04 UTC
I have updated linkchecker.spec and am waiting for the fedorapeople.org outage to be resolved.

Comment 3 Fedora Update System 2011-05-06 19:12:58 UTC
linkchecker-6.5-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/linkchecker-6.5-2.fc14

Comment 4 Fedora Update System 2011-05-07 02:57:08 UTC
linkchecker-6.5-2.fc14 has been pushed to the Fedora 14 testing repository.

Comment 5 Nathanael Noblet 2011-05-11 22:55:54 UTC
Package: linkchecker-gui-6.5-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Opened linkchecker
2.
3.


Comment
-----
installed via yum
Started it from the menu.

Comment 6 Nathanael Noblet 2011-05-11 23:01:41 UTC
Installed the linkchecker-6.5-2.fc14 from updates-testing. Absolutely no difference.

Traceback (most recent call last):
  File "/usr/bin/linkchecker-gui", line 23, in <module>
    from linkcheck.gui import LinkCheckerMain
  File "/usr/lib64/python2.7/site-packages/linkcheck/gui/__init__.py", line 29, in <module>
    from .options import LinkCheckerOptions
  File "/usr/lib64/python2.7/site-packages/linkcheck/gui/options.py", line 21, in <module>
    from .editor import EditorWindow
  File "/usr/lib64/python2.7/site-packages/linkcheck/gui/editor.py", line 20, in <module>
    from PyQt4 import Qsci, QtGui, QtCore
ImportError: cannot import name Qsci

Comment 7 Fedora Update System 2011-05-12 00:51:41 UTC
linkchecker-6.5-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/linkchecker-6.5-3.fc14

Comment 8 Fedora Update System 2011-05-12 01:23:04 UTC
linkchecker-6.5-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/linkchecker-6.5-3.fc15

Comment 9 W. Michael Petullo 2011-05-12 01:27:22 UTC
Something went wrong when I modified my workflow due to the fedorapeople.org outage. Please test these new builds. You may also install qscintilla-python by hand until the updates are available.

Comment 10 Miroslav Šustek 2011-05-16 13:03:40 UTC
Package: linkchecker-gui-6.5-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Just run
2.
3.


Comment
-----
Problem has gone after installing qscintilla-python (2.4.6-2.fc14 x86_64).

Comment 11 Fedora Update System 2011-05-19 04:59:32 UTC
linkchecker-6.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-05-29 23:20:53 UTC
linkchecker-6.5-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.