Bug 69734 - Mozilla does not work at all
Mozilla does not work at all
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-24 16:35 EDT by R. James Cross, Jr.
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-28 15:22:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R. James Cross, Jr. 2002-07-24 16:35:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I upgraded from Red Hat 7.1 to 7.3. Mozilla does not work. Clicking on the icon 
does nothing; running it from a command prompt, returns another prompt. I ran 
mozilla-rebuild-databases.pl, and this did not change the situation. Nautilus 
help also does not work, since it apparently calls Mozilla. I think some 
dependency is left out or some initialization is not done.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run Mozilla
2.
3.
	

Additional info:

I installed Mozilla and Mozilla-nspr. I tried reinstalling both. I tried 
installing M-psm, nss, mail. None worked.
Comment 1 Christopher Blizzard 2002-07-24 18:02:59 EDT
What doesn't work about it?  Does it crash on startup?  Does it exit suddenly? 
Does it hang?  I need a little more to go on.
Comment 2 R. James Cross, Jr. 2002-07-25 08:37:51 EDT
It apparently crashes on startup. If run from a command prompt, the disk light 
flashes once, and I immediately get another command prompt. No error message is 
printed and no entries are made in a log file. This happens every time I try to 
run it. Clicking the icon produces no result. In other words, I cannot be more 
specific, because it gives me no information on why it crashed. If you can tell 
me what to look for, I'll try to get more information.
Comment 3 Christopher Blizzard 2002-07-25 12:29:01 EDT
Sounds to me like the install is all screwed up.  What does bash -x
/usr/bin/mozilla tell you?
Comment 4 R. James Cross, Jr. 2002-07-26 09:42:14 EDT
bash -x /usr/bin/mozilla gives the following output

++ basename /usr/bin/mozilla
+ cmdname=mozilla
+ ulimit -c 0
+ MOZ_DIST_BIN=/usr/lib/mozilla
+ MOZ_PROGRAM=/usr/lib/mozilla/mozilla-bin
+ MOZ_CLIENT_PROGRAM=/usr/bin/mozilla-xremote-client
+ MOZILLA_FIVE_HOME=/usr/lib/mozilla
+ export MOZILLA_FIVE_HOME
+ '[' /usr/g98/bsd:/usr/g98/local:/usr/g98/extras:/usr/g98:/usr/gv/lib:/usr/g98/
bsd:/usr/g98/local:/usr/g98/extras:/usr/g98:/usr/gv/lib:/usr/g98/bsd:/usr/g98/lo
cal:/usr/g98/extras:/usr/g98:/usr/gv/lib ']'
+ 
LD_LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/plugins:/usr/g98/bsd:/usr/g98/
local:/usr/g98/extras:/usr/g98:/usr/gv/lib:/usr/g98/bsd:/usr/g98/local:/usr/g98/
extras:/usr/g98:/usr/gv/lib:/usr/g98/bsd:/usr/g98/local:/usr/g98/extras:/usr/g98
:/usr/gv/lib
+ export LD_LIBRARY_PATH
+ set_jvm_vars
+ '[' '!' -L /usr/lib/mozilla/plugins/libjavaplugin_oji.so ']'
+ return
++ check_running
++ /usr/bin/mozilla-xremote-client 'ping()'
++ RETURN_VAL=2
++ '[' 2 -eq 2 ']'
++ echo 0
++ return 0
+ ALREADY_RUNNING=0
+ '[' 0 -eq 1 ']'
+ '[' -z '' ']'
+ exec /usr/lib/mozilla/mozilla-bin
[cross@xbeams ~]$ 
Comment 5 Christopher Blizzard 2002-07-26 15:40:46 EDT
and if you just run /usr/lib/mozilla/mozilla-bin ?
Comment 6 R. James Cross, Jr. 2002-07-26 16:48:25 EDT
PROGRESS!!!! I ran mozilla-bin and got the following:

[cross@xbeams mozilla]$ mozilla-bin
**************************************************
nsNativeComponentLoader: SelfRegisterDll
(/usr/lib/mozilla/components/libmozucth.so) Load FAILED with 
error: /usr/lib/mozilla/components/libmozucth.so: undefined symbol: 
Implementation__C8nsString
**************************************************
**************************************************
nsNativeComponentLoader: SelfRegisterDll
(/usr/lib/mozilla/components/libpsmglue.so) Load FAILED with 
error: /usr/lib/mozilla/components/libpsmglue.so: undefined symbol: 
Implementation__C8nsString
**************************************************
*** Deferring registration of sample JS components
*** Registering sample JS components
IDN support disabled

*** a window opened asking if I wanted to create a profile bases on my Netscape 
profile. I clicked on yes ***

escpe UTF-8 enabled
IDN support disabled
escape UTF-8 enabled

*** The program hung here and I typed Contr. C to get a prompt ***

[cross@xbeams mozilla]$ 

After this, I tried again to run Mozilla without success. When I ran mozilla-
bin the mozilla browser appeared, pointing to Red Hat. It indeed updated my 
profile, because a third call to mozilla-bin brings up my home page. Nautilus 
still won't do help pages.
Comment 7 Christopher Blizzard 2002-07-26 16:59:38 EDT
You still have old .so libraries kicking around somewhere.  Remove all of the
Mozilla rpms, and let me know what you find.  There are probably some ok shared
libraries in the plugins/ directory but there probably shouldn't be anything
left.  Remove anything like components.reg or xpti.dat.  Try re-installing from
there.
Comment 8 R. James Cross, Jr. 2002-07-28 15:22:11 EDT
IT NOW WORKS!!!

I uninstalled all mozilla-* packages as well as nautilus-mozilla. After the 
removal, the directory /usr/lib/mozilla had the following entries:

chrome, components, defaults, libcmt.so, libgkgfx.so, libgtkembedmoz.so, 
libgtksuperwin.so, libgtkxtbin.so, libjsdom.so, libjsj.so, libmozjs.so, 
libmsgbaseutil.so, libnspr4.so, libplc4.so, libplds4.so, libprotocol.so, 
libxpcom.so, libxpistub.so, plugins, psm, psmdata, res, searchplugins, 
splash.xpm, start-psm.

The directory /usr/lib/mozilla/components contained the following:

cookieviewer.xpt, libmozucth.so, libnsgif.so, libnsjpg.so, libnsmng.so, 
libnspng.so, libpsmglue.so, libsample.so, libsigned.so, libsmime.so, 
libtimer_gtk.so, mozcomps.xpt, mozucth.xpt, nsSample.js, psmglue.xpt, 
sample.xpt.

All *.so files in both directories are dated March 16, 2001, obviously from a 
previous version.

I then renamed /usr/lib/mozilla to xxmozilla and reinstalled all the components 
from the CD. I tried mozilla. It offered to convert my bookmarks. I answered 
yes. It then appeared to hang and wouldn't restart. I found several instances 
of mozilla-bin in the process list and killed them all. Mozilla then started 
with my home page and appears to work. Nautilus help files now work. None of 
the *.so files in the old mozilla or mozilla/components appear to be in the new 
directories.

I have saved the old xxmozilla directory and its contents in case you want more 
information. Thanks!!

Comment 9 Christopher Blizzard 2002-07-29 11:56:09 EDT
No problem.  Sounds like something went terribly wrong with a previous install.
Comment 10 R. James Cross, Jr. 2002-07-30 14:45:23 EDT
Don't be so sure. I suspect that in an earlier version, the files were supposed 
to be in /usr/lib/mozilla, and they were moved to a different directory. When 
rpm tried to update the package, it tried to delete the files in the new 
location, leaving the old ones still there. The next question is why mozilla is 
still looking in the old directory for its files.

Note You need to log in before you can comment on or make changes to this bug.