Bug 697366 - Include DocBook 5-compatible templates
Include DocBook 5-compatible templates
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-17 23:29 EDT by Ruediger Landmann
Modified: 2013-12-18 21:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2011-04-17 23:29:44 EDT
Publican's templates for <book>, <article>, and <set> are not DocBook 5 compatible.

Specifically:
* <bookinfo>, <articleinfo>, and <setinfo> are all just <info> in DocBook 5
* <pubsnumber> is <biblioid>
* <corpauthor> is <orgname>
* the id= attribute is now xml:id throughout
* <firstname> and <surname> must be wrapped in <personname> in DocBook 5
* <revhistory> can no longer be a child of <simpara> (<para> works fine though)
Comment 1 Stephen Gordon 2013-01-07 14:51:29 EST
(In reply to comment #0)
> * <revhistory> can no longer be a child of <simpara> (<para> works fine
> though)

As it turns out the <revhistory> can actually be included directly in the <appendix>. I noticed another issue here though in that:

- <revhistory> cannot be included directly in the <book> (unlike an <article>) which is why we have it in an appendix.
- An <appendix> must have a title.
- A <revhistory> must also have a title.

The last of these appears to be new in DocBook 5 [1] (previously <revhistory> could only contain <revision> [2]). The result of this is we end up with redundant titling in our use case.

[1] http://www.docbook.org/tdg5/en/html/revhistory.html
[2] http://www.docbook.org/tdg/en/html/revhistory.html
Comment 2 Stephen Gordon 2013-01-07 14:56:03 EST
(In reply to comment #1)

Interestingly even when I do add a <title> to both the <appendix> and the <revhistory> elements I still get this error:

Element title in namespace '' encountered in revhistory, but no template matches.
Comment 3 Stephen Gordon 2013-01-09 12:55:36 EST
(In reply to comment #1)

> - A <revhistory> must also have a title.

Looking further this seems to be incorrect, the title is actually optional, though if you do choose to include it you do get the error I indicated in comment # 2.
Comment 4 HSS Product Manager 2013-09-10 19:57:32 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 5 Jeff Fearn 2013-09-10 22:35:21 EDT
The basic code is in place.

$ publican create --dtdver 5.0 --name Test_DB5_Book

"dtdver" is temporary, there will be a better named option after more splitting of hairs. But you can create and validate/build this DocBook5 book.

To ssh://git.fedorahosted.org/git/publican.git
   4be1028..7d23e61  HEAD -> devel
Comment 6 Jeff Fearn 2013-09-17 02:35:38 EDT
This is in place in devel branch and can be tested.

Suggestions on alternative names for --dtdver accepted.
Comment 7 Ruediger Landmann 2013-10-14 02:08:35 EDT
Working as advertised in publican-3.9.9-0.fc19.t6.noarch

Note You need to log in before you can comment on or make changes to this bug.